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About the Author - Pat Geary

Microsoft MVP - Expression Web (April 2007 - April 2013)
Expression Web Tutorials & Templates

Expression Web Tips

Genealogy Web Creations

| have been involved with website
design since the late 1990’s when |
created my first genealogy website on
the old GeoCities. I've come a long
way since those early days. | maintain
two RootsWeb (Genealogy) Mailing
Lists for FrontPage and Expression
Web. | am active on both the
RootsWeb and FreePages Help list for
genealogy websites as well as various
yahoo lists for FrontPage and
Expression Web where | provide
resources and answers to questions. |
am still an avid genealogist and
maintain Family Genealogy Online. Website design remains my love and | am webmaster of
Genealogy Web Creations, which specializes in website design for the genealogist with tips and
tutorials, resources, and css-based templates as well as a companion blog Genealogy Computer
Tips & Tutorials.

Expression Web Tutorials & Templates offers Expression Web resources and tutorials for all
versions of the program as well as FREE templates for your web design use. Expression Web
Tips is my WordPress blog which also provides short tutorials, resources, and news for the
Expression Web Community. Counted Cross-stitch is my other passion.

Tina Clarke who was also a Microsoft MVP — Expression Web (January 2003 — January 2014) and
| have coauthored two eBooks you might also find helpful. Launching a WordPress Blog is a
FREE eBook on setting up a WordPress Blog on your own domain. Migrating from FrontPage to
Expression Web is an eBook (for sale) that can help you in the process of moving from
FrontPage to Expression Web, and have a more standards-compliant site.

| live in the Shenandoah Valley of Virginia with my husband, Jim, and our dog Katie (pictured
above). Katie was adopted from our local SPCA.
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The tutorials included in this eBook were first published on my website Expression Web
Tutorials & Templates and offered in the First Edition in July 2010. This revision of the 2"
Edition has been updated to reflect the changes within Expression Web now that it is a Free
program. Also included are some of the basics for learning HTML and CSS.

2" Edition

Published: January 2011
Revised: September 2011
Revised: November 2011
Revised: May 2012
Revised: February 2013
Revised: April 2014
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Expression Web 4.0

Are you new to Microsoft Expression Web?

This article (http://support.microsoft.com/default.aspx?scid=kb;en-US;2511858) outlines the
prerequisites for using Expression Web effectively, along with a list of useful resources you can
use to get up to speed on modern Web design. The bottom line is that you do need to have
some knowledge of Web design before you’ll be comfortable or effective using Microsoft
Expression Web.

See Learning HTML - HyperText Markup Language for the basics of HTML and references.

See CSS Basics

Expression Studio 4.0 was launched on June 7, 2010. The most current version is 4.0.1460.0

which is the FREE version. Microsoft is no longer selling Expression Web and has made it
available to the public at no cost. You can read more about Microsoft
Expression Changes and download the Free version of Expression Web.

Eaqression Suded

The retail version of Expression Web 4 can be licensed and activated on,
at most, two systems, e.g., a laptop and a desktop. If you need to
reinstall on one of those systems, e.g., because you reinstalled Windows,
you should be able to reinstall Expression Web 4 and reactivate at that
time. The Free version of Expression Web may be installed on as many
computers as you wish. No activation is necessary. MICROSOFT OFFERS ONLY COMMUNITY
SUPPORT WITH THE FREE VERSION.

e

NOTE: If you have problems with licensing or activation issues, please see New Fix for Licensing
and Activation Issues with Expression Web 4.

What's New

Some areas of work and improvement include:

e SuperPreview online service is a beta service that extends the capability of
SuperPreview to include support for additional browsers and operating systems. You
will be able to see how your site displays on a Mac running Safari without owning a
Mac. SuperPreview now includes Internet Explorer 7 as a rendering option. You will
need to register to use this service. Expression SuperPreview Remote Beta will continue
running as a service through June 30, 2013.

¢ A new extensibility model that allows you to create add-ins much more easily
using html, css, javascript and a manifest file (xml). Anna Ulrich has an article on how to
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create add-ins for Expression Web 4 at Easily create an Add-in for Expression Web 4
with the Add-in Builder.

¢ A new Search Engine Optimization reporting tool that scans your site and warns you
about any SEO-related issues (See Help for the SEO rules). You can choose SEO options,
display an SEO report, filter the results in the SEO report, and step forward and back
through the list of results in the SEO report to see more detail for individual list items.
You can choose to do this for one page or the entire site.

Search Engine Optimization

Ll Problem Summary Help Topic ~ Page © Line ~ Issue Type
- LgThe <noscript> tag is missing. WEB1063 ewdfindex.html (Expression ... 2 Error
LgThe title and description for the page are the... WEB1045 ewd/findex.html (Expression ... 9 Warning
LgThe <img> or <area> tag does not have an JEB1009 ew4/findex.html (Expression ... 37 Warning
LﬁThe <a> tag text is too general to provide se... WEB1058 ewd4findex.html (Expression ... 57 Error
LgThe <a> tag text is too general to provide se... WEB1058 ewd/findex.html (Expression ... 230 Error

Q

Found 5 searchability problems in 1 page.

Figure 1: SEO

e Improvements to Publishing Ul (Publish All, Publish Changed, and Publish Current File

on on the Site menu) and fixes for "Publish Selected Files."
| PGl Data View Panels WebAssist Window Help

| New Site... Ctrl+Shift+N
# Open Site... Ctrl+Shift+0
Recent Sites L
Close
Publishing

Publishing Settings...
[ Publish Current File to "Expression Web Tutorials & Templates”  Ctrl+Shift+U
5 Publish Changed Files to "Expression Web Tutorials & Templates” Ctrl+Shift+H l}
(4 Publish All Files to "Expression Web Tutorials & Templates” Ctrl+Shift+A

Delete...
Export to Web Package...
Import L

Manage Sites List...
Site Settings...

Figure 2: Publishing Options

e Limited customization of toolbars. While you will NOT be able to customize any of the
current toolbars, you can create your own "Favorites" toolbar by using an Expression
Web add-in available in the Expression Gallery - Custom toolbars add-in for Expression
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Figure 3 - Favorites Toolbar Add-in.

e Many bugs reported by customers via Microsoft Connect have been fixed.
e The Free version of Expression Web also has the following bug fixes:
o Nested object tags are now supported
o Editing with external tools is supported (e.g., edit in NotePad) and files are saved
to the website folder rather than the temp folder
o Also the fact that you can now see editable regions outlined with an orange
border which did not work on EW4 even with SP2 installed.

Which Version Should | Get?

o Expression Studio 4 Web Professional
o Expression Studio 4 Ultimate
e Expression Web 4 (Free Version)

Only the free version of the program is now available although Amazon and some other online
distributors still offer the program for sale.

Additional Resources

o Expression Web 4 System Requirements

e Expression Web 4 FAQ (scroll down)

e Download Expression 4 Web Free Version

e Morten Rand-Hendricksen's First Impressions
e Paul Laberge’s post

e Expression Web 4 Add-in Friendly

e Expression Web 4.0 Add-ins

o Installing Expression Web 4

e Easy HTML & CSS with Expression Web 4
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Expression Web 4 Books and Videos

e Microsoft Expression Web 4 Step by Step by Chris Leeds

e Microsoft Expression Web 4 In Depth by Jim Cheshire

e Sams Teach Yourself Microsoft Expression Web 4 in 24 Hours by Morten Rand-Hendriksen
e Expression Web 4 Step by Step Videos by Chris Leeds (FREE)

e  Microsoft Expression Web 4 LiveLessons (Video Training) by Morten Rand-Hendriksen

Service Packs for Expression Web

These are only available for the retail versions. NOTE: The free version does not require the installation
of SP1 or 2.

Expression Web 4 Service Pack 1 (SP1)
Expression Web 4 Service Pack 1 (SP1) was released 3/17/2011 and applies significant fixes and

improvements to publishing, SuperPreview, file management, extensibility, and other areas of the
programs.

Issues that are resolved in this service pack:

e Fixed several issues to improve product stability.

e PHP include statements now update when included filename is changed in Web.

e PHP pages now correctly start the development server when they are previewed.

e Improved Insert Silverlight video.

e Improved performance of Team Foundation Source Control with large sites.

e Improved Ul behavior of the Publishing pane.

e User-selected character encoding for a page is now correctly recognized, resolving problems
with extended characters.

e Linking to a bookmark at a remote URL now works correctly.

e The Bookmark dialog box now displays the correct hyperlink.

e CSS IntelliSense no longer reports errors for valid values.

e Replacing text in table cells now functions correctly.

Improvements that are provided by this service pack:

HTML 5

Expression Web 4 SP1 provides support for all HTMLS5 tags (for pages authored using the HTML 5
doctype) via IntelliSense within the code editor, and as block or inline entities in the Design view. There
is no preview for <canvas> or <svg> elements, and no specific IntelliSense for SVG entities.

CSSs3
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Expression Web provides support for the draft CSS 3 specification. To enable CSS 3 error checking, you
must choose CSS 3 draft from the Schemaversion drop-down under the Authoring tab in the Page
Editor Options dialog.

The IntelliSense and error-checking in the code editor is fairly complete, and supports checking multiple
comma-separated property values (e.g. multiple backgrounds). This support extends to the
CSSProperties pane, as well.

SP1 also provides support for selected CSS 3 properties in the New Style and Modify Style dialog boxes,
including "border-radius" and "box-shadow."

Note: There is no support in the Design view for previewing CSS 3 properties.

SuperPreview Access to Pages Protected by Authentication Forms

SuperPreview now supports cookie-based logon authentication. You can click on the "Page Interaction
Mode" icon, browse to the page of interest, enter your login credentials, and view the rendered page.
Because of the wide variety of different authentication methods used on the Internet, some sites may
not be compatible with this feature.

PHP IntelliSense

IntelliSense now includes an expanded number of function groups that improve PHP coverage and
utility.

Internet Explorer 8 and Internet Explorer 9 Beta

Internet Explorer 9 beta is now supported as a local browser for both SuperPreview and the Expression
Web Snapshot feature. Internet Explorer 8 is now built into SuperPreview. If you have Internet Explorer
9 beta installed, you can view page renderings in Internet Explorer 6, 7, 8, and 9 beta.

Additional updates and features:

e The PHP function list has hundreds of new methods, including PHP5 functions.

e The new Open as PHP option allows Expression Web to recognize PHP files even if they don't
have a PHP extension. Right-click on a file in the folder list, and choose Open as PHP.

e Expression Web and SuperPreview automatically check for Chrome, Safari, and Opera and add
them to the list of browsers you can use to preview.

e JavaScript (.js) files now display IntelliSense for methods associated with the document object
(for example, document.getElementByld()).

e When you click New in the File menu, the list of available file types now includes JavaScript.
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e New IntelliSense is included for extended characters—so, as soon as you type an ampersand
(“&”), you’ll get a list of the HTML character entities that is filtered as you continue to type.

o The Copy Full Path command is now available when you right-click on a file in the folder list. This
command copies the file path to the clipboard.

e The Open Folder in Windows Explorer command is now available when you right-click on a file
in the folder list. This command opens a Windows Explorer window.

e Expression Web 4 now works substantially faster with sites stored in Team Foundation Server.

Download Expression Web 4 Service Pack 1

Expression Web 4 Service Pack 2 (SP2)
Microsoft Expression Web 4 Service Pack 2 (SP2) contains significant fixes and improvements in support

for jQuery, image thumbnails in the Folder List panel, a new Snippets panel, and in other areas of the
program.

Issues that are resolved in this service pack

e Fixed several issues improving product stability.

e Fixed items and visuals in the Insert Symbol dialog.

e The CSS property "overflow: hidden" now behaves correctly on the design surface.

e Improved handling of the HTML "name" attribute.

e Added a notification error in Snapshot panel.

e Fixed online help links in several places.

e Fixed an issue with Copy/Paste in the Folder List panel.

e Fixed an issue in which CSS media queries were removed by the "Reformat HTML" command.

e Fixed several issues that affected the formatting of special characters and symbols.

e Src and link handling now allows protocol-relative URLs.

e Fixed an issue in which deleting a table row or column through the context menu caused
unexpected behavior.

e The Hyperlink dialog now properly handles links that are already URL-encoded.

e The CSS property "pre-wrap" now behaves correctly on the design surface.

e Fixed ALT+F1 shortcut for the Folder List panel.

e Fixes to the JavaScript extensibility model.

Improvements provided by this service pack

jQuery support

IntelliSense has been added for jQuery. In addition to the jQuery functions themselves, this provide
IntelliSense for ids and classes in your document when creating jQuery selectors. It also includes the

ability to continuously chain jQuery function calls and obtain IntelliSense.

New Snippets Panel and improved Snippets behavior.
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Snippets now appear in their own panel. This panel provides all the previous functionality of the
snippets feature, including keyboard accessibility from Code View with CTRL+ENTER. Snippets previously
created by the user will be automatically migrated to the new snippet format and appear in the Snippets
panel.

In addition, the Snippets panel provides the following improvements:

e Ability to create folders to categorize your snippets.

e Ability to create wrap snippets—with before and after sections—that you can use to surround
text you select in Code view.

e Includes a large number of new sample snippets across several categories.

e Ability to quickly search the Snippets panel to find snippets by name, description, and the code
of the snippet itself.

Snippets L
Options ¥
4 [ JCSS
_J Action
4 | ) Effect
l%l Box Shadow
[% Circle
[%I Horizontal-Vertical align
[%Image Button
[%l Opacity Hack
[%l Rotate Box

Rounded Corners
4 | JText
Change Color of Selected Text
[E] Disable Select Text
First letter in color and uppercase

Tex‘t-Ou‘tIine
I [ Doctypes
4 [ JHTML

Definition List

| mySnippets

Figure 4 - Improved Snippets Panel

Image Thumbnails in the Folder List Panel

The Folder List now provides an image thumbnail preview in Windows 7 and Vista. This includes
information such as file size, width, and height of the image for reference. Quick links, next to the image,
CSS, and JavaScript files, copy relevant markup to the clipboard, and paste it into your code.
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Folder List

add-images.jpg
1.23 KB, 32 x 30 px

= n images

m W boed7boe

-] u extra
2 2nd-edition-cover.jpg
Eg 404.gif
f«' 404-red.tlc
" accessibility-options.j
LA acce lity-properties.png
8 accordian-menu-advancer_small.j
[ add-browser.jpg
"8 add-font-family.jpg
" add-font-family_small1.jpg

LA adjust-hyperli
[ advanced-css-menu.jpg

Figure 5 —=Thumbnails in Folder View

Interactive Snapshot Panel

The Snapshot panel now provides an Interactive mode for both Internet Explorer and Firefox. This mode
allows you to preview dynamic content and code in a browser inside Expression Web. All JavaScript and
other interactive content will behave just as if you used the Preview in Browser command.

Snapshot

/= Internet Explorer (Interactive) ¥

{e Internet Explorer (Interactive) %

@ Firefox (Interactive)

@ Internet Explorer 6

C

@ Internet Explorer 7

-

{e Internet Explorer 8 (Compatibility View)

@ Internet Explorer 8

C

e Firefox 3.6.18

Figure 6 - Interactive Snapshot Panel

Universal comment/uncomment
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Code view now provides context-sensitive comment and uncomment functionality. The appropriate
type of comment will be inserted, depending on the type of code block you currently have selected in
your document. Comment/uncomment supports HTML, CSS, PHP, and JavaScript.

Workspaces

Customers can now define and save multiple layouts of their application and panels. Several starter
workspace layouts are provided. In addition you can create your own panel layouts and save them to
custom workspaces of your choosing.

ELE BNV ebAssist  Window  Help

Workspaces » v Designer
Developer
Developer (Snapshot)
Reporting

Manage Workspaces...

Save as New Workspace...

Figure 7 - Workspaces Panel

Custom Toolbars

The popular Custom Toolbars Add-in has been directly built into the application, enabling you to create
and name multiple custom toolbars and to add items of your choosing to each of them.

Custom Toolbars

EEE CleanUp - Rename Delete

Table to Text

Page Editor

) Indude Page...

Figure 8 - Custom Toolbars Dialog
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Look and feel improvements to the Code View

Code now uses the popular Consolas font by default. Color and syntax highlighting in Code view have

also been improved.

DOWNLOAD Microsoft Expression Web 4 Service Pack 2

You can tell if SP2 is installed by clicking About Microsoft Expression Web from the Help menu. If
Expression Web 4 SP2 is installed, the following version number appears: Microsoft Expression Web 4
Version 4.0.1303.0 SP2.
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User Interface - Changes to the User Interface

If you are upgrading from Expression Web 3.0 to version 4, you will notice very little change in
the user interface. If, however, you are moving from an earlier version (1.0 or 2.0) there have
been some major changes to the Ul.

Expression Web 3 and 4 follow the same look and feel found throughout Expression Studio. This
consistent, uniform interface is new for Expression Web 3 and 4.

With the release of Service Pack 1 for Expression Web 3 and in Expression Web 4, you now have
the ability to choose between an improved black and gray color scheme which is the default,
that better reflects the appearance of the Microsoft Expression Studio family of products or the
Windows color scheme.

You cannot customize the menus or toolbars in Expression Web 3.0 or 4.0. To give you an idea
of the difference in how the various versions of Expression Web look looks, see the screenshots
below:

Figure 9 - EW 2.0 User Interface Figure 10 - Expression Web 3.0 and 4.0 Figure 11 - Expression Web 3.0 and 4.0
Default User Interface Windows Color Scheme User Interface

'E'xpressic:... = C:‘{[jsers‘.,l'?... .

Figure 12 — Left EW 3 and 4 Right EW 2.0 Program Tab

Some menu items have also been removed or changed to a different location.

Site management

One of the biggest changes from an earlier version to Expression Web 3 and 4 is to site
management. Expression Web provides new tools to help you publish content to your site.
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With Expression Web 2.0 much of the site management functions were done through the 'File'
menu which included:

File > New > Website

File > Open Site

File > Close Site

File > Publish Site

File > Import > Import Site Wizard
File > Import > Personal Web Package
File > Export > Personal Web Package
File > Recent Sites

" Edit View Insert Format
J New. 4
New €55 Sculptar Page—.
= Dpen. Cirle0

%5 OpenSite..

Close Site

Publish Site._
Import
Export

Preview in Browser

v v wow

Properties.,

Recent Eiles »

Recent Sites L4
*  Exit

Figure 13 - Expression Web 2.0 File Menu

In Expression Web 3.0, these functions have been moved to the 'Site' menu

Site > New Site

Site > Open Site

Site > Recent Sites

Site > Publishing

Site > Publishing Settings

Site > Export to Web Package

Site > Import > From Web Package
Site > Import > Import Site Wizard
Site > Manage Sites List

Site > Site Settings

Sl Data View Panels Wing
. New Site... I}

:j Open Site...
Recent Sites r

Close

Publishing
Publishing Settings...

Delete...
Export to Web Package..
Import L

Manage Sites List...
Site Settings...

Figure 14 - Expression Web 3.0 Site Menu

In Expression Web 4.0, some additional functions have been added to the ‘Site’ menu

|Site Data View Panels WebAssist Window Help

] New Site.
:j Open Site,

Ctrl+Shift+N
[} Ctrl+Shift+0

Recent Sites L4

Close

Publishing
Publishing

Publish Cu

Settings...

rrent File to "Expression Web Tutorials & Templates Ctrl+Shift+U

3 Publish Changed Files to "Expression Web Tutorials & Templates” Ctrl+Shift+H
(-'p Publish All Files to "Expression Web Tutorials & Templates” Ctrl+Shift+A

Delete...

Export to Web Package..

Import

Manage Sites List.

Site Settings...

Figure 15: Expression Web 4.0 Site Menu

e Sjte > New Site

e Site > Open Site

e Site > Recent Sites

e Site > Publishing

e Site > Publishing Settings

e Site > Publish Current File

e Site > Publish Changed Files
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e Site > Publish All Files

e Site > Delete

e Site > Export to Web Package

e Site > Import > From Web Package
e Site > Import > Import Site Wizard
e Site > Manage Sites List

Task Panes now Panels

'Task Panes' in the earlier versions have been renamed to 'Panels' in Expression Web 3.0 and
4.0. You can have multiple panels open at one time and change the location and size of each
panel to suit your needs. When you first start Expression Web 3.0 and 4.0, the 'Folder List', 'Tag
Properties', 'Apply Styles', and 'Toolbox' panels will be docked on either side of the editing
window.

Figure 16 - Expression Web 4.0 Default Workspace

Once you rearrange the panels in a layout that works for you, Expression Web automatically
uses this layout the next time you start the program. | prefer mine docked on the left-hand side
of my workspace. You can also autohide the panels. Check Help > User Guide for additional
information on each of the 'Panels' available to you.

Include Page Option

The Include Page option is no longer available on the Insert menu, and you cannot add it.
Include Page IS AVAILABLE from the 'Standard Toolbar' (Figure 17 - Standard Toolbar Include
Page Icon) or the ‘Common Toolbar’ or you can create a code snippet.
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Include Page..

Figure 17 - Standard Toolbar Include Page Icon

Snapshot Panel

The 'Snapshot' panel displays a browser rendering of an HTML, PHP, ASP, or ASPX page that is
updated every time you save the page. The Snapshot panel works from inside Expression Web
AND you can move the panel and dock it wherever you like or AutoHide it. You can use the
dropdown list to choose which browser the page will be displayed in and which screen size will
be used.

With the release of Service Pack 2, Interactive Mode has been added to Snapshot. SP2, puts
Internet Explorer (current installed version) in a panel, and allows you to see and interact with
web pages during the authoring process. Any mouse-overs, lightboxes and animations all work.
Firefox is also available in the interactive Mode. (See Figure 6 - Interactive Snapshot Panel)

To activate Snapshot

e On the Panels menu > click Snapshot. The Snapshot panel appears.
e On the View menu > click Page > click Snapshot.

iy

. R Fiession b ...~

Dropdwn ttoriale and [,pmp]am Dropdown

Search T Site

=

Figure 18 - Snapshot Panel

SlapShot
SlapShot is a new extension written for Expression Web 4. For those of you who already use the
SnapShot panel (a feature that debuted in Expression Web 3), you will feel right at home with SlapShot.

SlapShot is based on the same premise in that you can easily preview a page
without loading a browser, however SlapShot extends the features of SnapShot
by including full ActiveX support (Silverlight®, Flash®, and so on), as well as
interactivity within the page (including navigation).

For a detailed tutorial Snapshot and Snapshot Interactive Online by Tina Clarke.
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SuperPreview

'SuperPreview' (Figure 19 - Screenshot SuperPreview) is available from within Expression Web.
It allows you to preview and compare pages simultaneously in multiple browsers, as well as in
multiple versions of Internet Explorer. You can also compare browser views against a
comprehensive mock-up ("comp") image. You can select individual elements within a page and
see details about each selected element, helping you quickly find and fix cross-browser layout
and positioning errors.

Debug your pages in multiple browsers on the same machine that you use for development
with Expression Web SuperPreview. SuperPreview supports Internet Explorer, Firefox with a
local client, and Macintosh Safari with an online service beta. Internet Explorer 9 (beta) is also
supported via the online service.

Expression SuperPreview Remote Beta will continue running as a service through June 30, 2013.

Srarch Toe S
[ G

WA MENU

Go

MAIN MENU

Harne
Avout

0 0 our ca
in Expression Wb, 15 SumerPreviei 1 cOmDAre your papss = muipe.
browsers You can sven vy i
brawsars to traudlashaet layout end pasitioning arrors.

Upgrade Information and Pricing
Resourcss

ek Trsi Downlasd and Relsese Notes
Addons £143 USD Upgrade §75 USD. 1 you sre & 1
EW Tips Blog thiad paxty tacks, yau ara abgitie 1o vpgrads

EW for Newbies

ol
Expiession verson 3 o he upgrade p

Expraseion Web .0 Yol Lt & Kcensad User of onaaf th Tokwng pIOGUCS 1 b4 ekt fo e Loprace
T o Ay Microsofe® Expressin product

+ By Adots Cicalie Sute product

o Aoy Microsoft Ofce produc (o FrontPage, ShosePoint Desxrar)

Expression Web V3.0 Reviews

o
Auto thumbnai in

Figure 19 - Screenshot SuperPreview

SuperPreview Resources

Tina Clarke’s detailed tutorial Expression Web 3.0 SuperPreview

SuperPreview Online Service in Expression Web 4 SP 1 by Tina Clarke

Activating SuperPreview online service

The SuperPreview workspace by Microsoft

Cross-browser Development with SuperPreview from SitePoint

Microsoft Expression Web 4 SuperPreview Online: See Your Website as Others See It
Displaying pages in SuperPreview
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Next Step: Installing Expression Web 4.0
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Installing Expression Web 4

The free upgrade from Expression Web 3 to Expression Web 4 is no longer available. If you
were eligible and still have the program burned to a disk then you can install it. If not, your only
option is the free version of the program.

Licensing

The retail version of Expression Web 4 can be licensed and activated on, at most, two systems,
e.g., a laptop and a desktop. The free version of Expression Web 4 can be installed on as many
machines as you wish and requires no activation.

If you need to reinstall on one of those systems, e.g., because you reinstalled Windows, you
should be able to reinstall Expression Web 4 and reactivate at that time.

IMPORTANT NOTE: If you are having a problem with Expression Web activation or if the
product will not accept your product key, you may have a corrupt license store. That problem
often cannot be resolved without the assistance of Microsoft Consumer Technical Support.
Please check out the post Forum FAQ and Guidelines - Start Here for solutions.

Download Links:

e Expression Web free version

Note: Screenshots were done installing Expression Studio Ultimate on a Windows Vista
machine.

Installation

NOTE: Before you can install Expression Web (either version), you will need to have .NET
Framework 4.0 installed. You may want to go ahead and download and install it as your
computer will need a restart after installation. If you do not install it first, then you will be
prompted to do so BEFORE you can continue with the EW installation.
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Setup

I.-"'_"“-. This software requires Microsoft NET Framewaork 4, Do you want to
'Y download and install Microsoft [NET Framewaork 4 now?

Figure 20: Microsoft .NET Framework 4 Install message.

Step 1: Once you have downloaded the program file, double click on the file to start the
installation. You will receive the normal User Account Control warning box. Click Yes. You will
see the screen shown below as the install process starts.

Microsoft:

Expression Studio 4
Ultimate

Please wait while setup initializes,

Figure 21: Expression Studio 4 Ultimate Install Screen.

NOTE: If your are installing a retail version of Expression Studio 4 Web Professional OR
Expression Studio 4 Ultimate, you will be prompted at this point to enter your Product Code.
You will NOT receive this prompt if you are installing the free version.

Enter product key

Key is valid. Thank you! @

[# Activate Microsoft Expression Studio 4 Ultimate.
What is activation?
View Privacy Statement.

€= Back . NE<t;)-_; Cancel

Figure 22: Enter Product Key screen.

Step 2: Accept the license agreement.
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License agreement

You must accept the terms of this agreement to continue. If you do not want
to accept the Microsoft Software License Terms, click Decline.

MICROSOFT SOFTWARE LICENSE TERMS

MICROSOFT EXPRESSION STUDIO 4 DESIGN SOFTWARE
AND TRIAL EDITIONS

These license terms are an agreement between Microsoft Corporation
(or based on where you live, one of its affiliates) and you. Please
read them. They apply to the software named above, which includes
the media on which you received it, if any. The terms also apply to
any Microsoft

T Ereat

Accept | Decline |

Figure 23: License agreement.

Step 3: Choose whether you wish to join the Customer Experience Improvement Program.

- X

Join the Customer Experience Improvement
Program
Would you like to help improve Microsoft Expression Studio 4 Ultimate by

joining the Customer Experience Improvement Program to periodically send
basic performance and usage information to Microsoft?

Yes
No
Privacy Statement

€ Back | Next=> | Cancel

Figure 24: Join the Customer Experience Program.

Step 4: Select which of the programs you wish to install.

Installation
Choose the programs you want to install:
| Expression Web 4

Expression Blend 4 + SketchFlow

Expression Blend SDK for NET 4 (6]

© ®
RIRIRR

Expression Blend SDK for Silverlight 4 (D

&

&3]
3

Silverlight 4 SDK

|

S YR ey

Options.

-

€ Back || Install | Cancel

Figure 25: Which Programs to Install Screen.
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Step 5: Once all of the program you have selected are installed, you will see the finish setup
screen. You can either view the Release Notes of click Finish.

Thank you

Setup has successfully installed Microsoft Expression Studio 4 Ultimate.

View release notes

Finish

Figure 26: Installation Complete.

Once you have installed Expression Web, you should obtain Service Pak 2. It can also be installed via
Windows Update.

NOTE: The free version does not require the installation of SP1 or 2.

Activating Expression Studio

Step 6: Launch Expression Web 4.0. Click on the 'Help' menu and choose 'Activate Product.'
You can then check ‘About Microsoft Expression Web' from the Help menu and you should see
that you now have a fully licensed copy.

NOTE: The free version of Expression Web does NOT require activation.
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Microsoft® Expression Web™ Version 4.0.1165.0

This is a fully licensed copy.

Product Code Removed

Warning: This computer program is protected by A

copyright laws and international treaties. E
. Unauthorized reproduction or redistribution of this . '
i

program, or any portion of it, may result in severe

civil and criminal penalties, and will be prosecuted to

the maximum extent possible under the law. Microsoft
and Expression Web are trademarks of the Microsoft +

Full optimized rendering is supported by your system and
video drivers.

All rights reserved. Glose
Figure 27: About Expression Web 4 Product Screen.

Important: If you took advantage of the free upgrade from version 3 to version 4, save your
copy of version 3! If you need to reinstall Expression Web 4, after you have reformatted your
computer, for example, you will need to first install version 3, then install version 4.

If you have not reformatted your computer but only need to reinstall the program, you should
not have any problem, as the version 3 license will still be in the Windows license store even if

you had previously uninstalled version 3.

IMPORTANT NOTE: The free upgrade is no longer available for download.

Installation and Activation Help

If you are having problems installing or activating Expression Web, make sure and check the
“Forum FAQ and Guidelines - Start Here” sticky on the Microsoft Forum for some of the Known

Issues and Resolutions. You will need to scroll down to the bold-face headings for:

e Common Questions and Problems
e Installation FAQs
e More Microsoft Resources for Installation Problems
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New Fix for Licensing and Activation Issues with Expression Web 4
Microsoft has just released a fix for licensing and activation issues that crop up with Expression Web 4.
Some of the symptoms of licensing and/or activation issues may include:

e Expression Web 4 reverts to trial mode.

e You receive a message that states the product key is invalid.

e The product key is not accepted during the Expression Web 4 installation process.

e You receive a message that states Expression Web 4 was already activated with the product

key.

If you are experiencing any such problems, the fix Microsoft has released should resolve the issue. For
additional details and to download the fix go to:

http://support.microsoft.com/default.aspx?scid=kb;en-US;2635101

To download the fix, click the “View and request hotfix downloads” hyperlink at the beginning of the
article. You will first have to accept the Terms & Conditions BEFORE being directed to the download

page.

This fix is only for Expression Web 4. If you encounter a licensing or activation issue with another
Expression Studio product, you will need to open a support case with Microsoft to get that issue
resolved. To open a support ticket with Microsoft see Forum FAQ and Guidelines — Start Here and scroll
down to the 3rd bold-faced item which states, in part:

If you are having a problem with Expression Web activation or if the product will
not accept your product key, you may have a corrupt license store. That problem
often cannot be resolved without the assistance of Microsoft Consumer Technical
Support. For these issues, you can open a case with us using the steps outlined
above. There will be no charge for these cases. Using any other method to contact
Microsoft will not get you to the right group. Please contact us using the method
outlined above.

If you download the patch and you receive an error that Web_en.msi could not be located, please
download the “FullFile” version of the fix and install it on top of your existing installation. This will
upgrade your existing installation of Expression Web 4 to SP2a which includes the fix. See the download

link listed above.
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Setting Up Expression Web 4.0

Now that you have installed Expression Web 4.0, you can make some changes in the default
setup of the program that will make Expression Web easier to work with. These changes to the
setup can also reduce your frustration level with the code that is created and enhance your
working experience.

This page is a brief summary of the various settings. Each of these is explained in greater detail
in Tina Clarke's FREE Setting Up Expression Web 4.0 EBook which has been revised to include
Service Packs 1 and 2.

NOTE: If the default black color scheme is NOT to your liking and you want to change and use
your Windows Color Scheme rather than the default, Tools > Application Options > General Tab
> Use your current Windows color scheme. The result will depend on what color scheme you
are using.

View Screenshot Default Color Scheme
View Screenshot Windows Color Scheme

HTML <!IDOCTYPE> Declaration

The default doctype used by Expression Web 4 for new documents is:

<IDOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.0rg/TR/xhtml1/DTD/xhtml1-
transitional.dtd"> <html xmIns="http://www.w3.0rg/1999/xhtml">

If you are moving from FrontPage or another web editor you may not have any doctype
declaration on your pages. Why is it important to include a doctype declaration as part of your
page?

The doctype you use will influence the way browsers render your page. The lack
of a doctype (or the presence of an invalid one) can change the layout of your
page completely, as the browser will use quirks mode instead of standards mode
to interpret your code. As the name suggests, you can expect the render to
include a few quirks if you take this route. ~ Sitepoint ~

To add or change the DocType declaration in an existing page

With the page open in Code View, do one of the following:

e If your page already has a DocType declaration, select the entire DocType declaration.
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e If there is NO DocType declaration, place your cursor at the very top of the page before all other
code in your page.

Do one of the following:

e Press CTRL+ ENTER (NOTE: If you have SP2 installed the Code Snippets Panel will become
available)

e On the Edit menu, point to IntelliSense, and then click List Code Snippets. (Not available with
SP2)

e Onthe Code View toolbar, click List Code Snippets (Not available with SP2)
In the list of code snippets, do one of the following:
e Type the keyword for the code snippet, and then press ENTER or TAB to insert it.

e Select the code snippet you want to insert, and then press ENTER or TAB to insert it.
e Double-click the code snippet you want to insert.

HTML 5 doctype and Intellisense
There are 3 different doctypes in HTML 4.01, In HTMLS there is only one: <!DOCTYPE>

If you wish to use HTMLS5 as your default doctype, you need to change your page editor options choose
Tools > Page Editor Options. On the Authoring tab, set both the Document Type Declaration option and
Secondary Schema options to HTML5.
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Page Editor Options @-s;_hj

‘ General | AutoThumbnail | Default Fonts | Code Formatting l Css l Color Coding
Authoring | Ficture | Code Snippets | Ruler and Grid | IntelliSense | Font Families

Mews Documents

Choose the default type of new documents and the default file extension of new
HTML documents.

Default Document: Add a byte order mark (BOM) when
HTML = creating or renaming UTF-8 documents
with these file extensions
Default HTML File Extension: [C].htm  [.js
@ _html | |.html|.php
2 I]-css  |].bd
() .htm .dwit xml

Doctype and Secondary Schema

Choose the doctype declaration to be inserted into new pages. A matching document
schema will be used to drive incompatibility notifications and IntelliSense for HTML
and script. If a page has no doctype or an unrecognized doctype is declared, the
Secondary Schema will be used.

Document Type Declaration: Secondary Schema:

[Hrmas -] ML s -
-

CSS Schema -

This schema determines what is available in CSS IntelliSense.
Schema version:
CS5.2.1 -

oK ] ’ Cancel

Figure 28 - Page Editor Options for HTML5 schemas.

Once you have changed the Page Editor options Authoring tab to reflect the HTML5 schemas,
whenever you create a new web page in Expression Web, the new page contains the HTML5
doctype which is:

<IDOCTYPE html>

Now, when you edit an HTML5 document in code view, Expression Web 4 now provides
IntelliSense for HTML 5 elements, attributes and their values.

*** IMPORTANT UPDATE ***

The HTML5 Schema Configuration Add-In for Expression WebAdd-in is now superseded by Expression
Web 4 SP1! Service Pack 1 adds many more features than just HTML 5 intellisense, including support for
the CSS3 draft specification! If you've downloaded this HTML 5 Add-In the past, it's no longer needed
and can be removed. Go to Tools > Add-ins > Select HTML 5 Schema Configuration > Click Remove
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Manage Add-ins
The selected add-ins load when Expression Web starts.
Available add-ins:
B C Install...

Remove

HTML 5 Schema Configuration
Description: Updates the HTML 5 schema for Expression Web 4
Home Page:
Author: Microsoft Expression Web Team

® i
b
L
v
v
v
b4
v

Figure 29 - Manage Add-ins.

Tools > Page Editor Options > General Tab
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Page Editor Options @Iﬂ:—hJ

| Authoring | Picture | Code Snippets | Ruler and Grid | IntelliSense | Font Families
General | AutoThumbnail | Default Fonts | Code Formatting | C55 | Color Coding

[¢] automatically enclose form fields within a form
["] Assign unique IDs to new tables
[#] Make ID unique on paste
[#]use <strong> and <em= when using bold and italic toolbar buttons
[] Automatically switch keyboard to match language of surrounding text
[ "] Automatically add 'lang' attributes to international text
[#] Prompt for accessibility properties when inserting images
Spelling

Spelling Options...

Default Page Language:  English (United States) -

Cut and Paste Options
[/]Show Paste Options buttons
Code View Options
[ word wrap [¥] Highlight invalid HTML
[¥] Auto indent Highlight incompatible HTML
[]Line numbers
[ selection margin

Security Options

DAIIUW unsigned ActiveX controls to be run Clear ActiveX Security Settings l
and prompt for permission to run them

What's the risk?

o ] [ conee

Figure 30: Page Editor Options > General Tab
| tick everything except:
e Assign unique IDs to new tables
e Selection margin
e Automatically switch keyboard to language of surrounding text

e Automatically add 'lang' attributes to international text (New to EW4)

Spelling

Click the button for spelling Options under Spelling and un-tick the radio button for 'Ignore
spellings in uppercase'

If you need to change the options for spelling to cover UK spellings, you will need to make the
change in two places:

Tools > Page Editor Options > General tab — Spelling: Set Spelling language from the drop-
down AND

Tools > Spelling Options > Custom Dictionaries > Set this to English (UK) as well from the drop-
down.
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Cut and Paste Options

Make sure 'Show Paste Options buttons' is ticked which will display the Paste Options button
when you paste text or elements into a page. When you click the button, a list appears with
options for pasting the text or element.

Code View Options

| tick everything except:

e Word wrap
e Selection margin

Two of the most important ones are that should always be ticked are:

e Highlight Invalid HTML which will display invalid HTML in a specific color scheme (the default is
red text on a yellow background). If you choose to change the colors, you can specify this color
scheme in the Color Coding tab of the Page Editor Options dialog box.

¢ Highlight Incompatible HTML which will display a wavy underline beneath code that isn't
compatible with HTML standards.

Tools > Page Editor Options > Code Formatting Tab
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Page Editor Options @éj

Authoring I Picture | Code Snippets | Ruler and Grid IntelliSense Font Families |
General I AutoThumbnail | Default Fonts | Code Formatting css Color Coding

Base on current page Tab size: h 4 2| characters
[#]Tag names are lowercasa Indent: 1 =
[¥] Attribute names are lowercase Right margin: |2000 | characters

[ Attribute names are alphabetized [ Insert tabs as spaces

[:]Allow line breaks within tags

Tags:

address - Line Breaks

applet = Before start: [ ‘| After start: [ =
area == 2 . b =
base Before end: | * Afterend: | =
basefont 2 =
bgsound it st i Scati v
biockquote Omit start tag Indent contents

body il Omit end tag

C55:

selector e Formatting

opening brace Lines before: | * Llines after: |g =
property name il sl
property value Spaces after: | :

closing brace = =

[¥]indent properties on new lines

[#]use shorthand praperties when generating styles in Design view

Reset

oK I’ Cancel ]

Figure 31: Page Editor Options > Code Formatting Tab

Tick 'tag names are lowercase' and 'attribute names are lowercase' - the default doctype for
Expression Web 4 is XHTML, which requires all code be written in lowercase. Even if you decide
to change your doctype to HTML rather than XHTML, it is a good habit to get into and will make
a future change easier.

'Attribute names are alphabetized' is ticked by default. If you leave the default setting, your
meta tags will NOT remain in the order you set BUT will be reorganized in A-Z order. |
recommend NOT having this selection ticked.

Tick 'indent properties on new line.'

Tick 'Use shorthand properties when generating styles.' Use shorthand CSS attributes instead
of longhand. As an example, with this option selected, Expression Web would define the values
of the width, color and style of a border by setting only the border attribute in the style.

Example Using Shorthand: #masthead {border: 1px solid #000000;}

With this option cleared, Expression Web would set an attribute and value for each border
attribute.

Example using longhand:
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#masthead {

border-bottom:1px solid #000000;
border-left:1px solid #000000;
border-right:1px solid #000000;
border-top:1px solid #000000; }

Both accomplish the same style BUT the shorthand code is much shorter.

If you set the Right Margin at a high number (2000), this will keep your code from wrapping.

Tools > Page Editor Options > CSS Tab

Page Editor Options @Iﬁ_hj

Authoring | Picture | Code Snippets | Ruler and Grid | IntelliSense | Font Families
General | AutoThumbnail | Default Fonts | Code Formatting | Cs5 | Color Coding

(@) Auto Style Application
() Manual Style Application

Select which technology to use for the following properties:

Page properties on the <body> tag: lcss (rules) v]
Font and text: lCSS (classes) i ]
Background: lcSS (classes) ']
Borders: lCSS (classes) ']
Padding and margins: lcss (classes) ']
Sizing, positioning, and floating: lcss (classes) v]
Bullets and numbering: lcss (classes) ']

["| only reuse classes with the prefix "style"
Use width and height attributes for images instead of CSS

Reset Defaults

OK l [ Cancel

Figure 32: Page Editor Options > CSS Tab

If you are new to CSS, tick the 'Auto Style Application.'

The Page properties on the <body> tag should be set to rules and everything else to classes
e Page properties on the <body>tag

e Fontand text
e Background
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e Borders

e Padding and margins

e Sizing, positioning, and floating
e Bullets and numbering

Only reuse classes with the prefix style' option

If you tend to use the formatting toolbar to add styling to your page, which is not a good habit
to get into, you may also wish to check the 'Only reuse classes with the prefix style' option.
Why? Your page can quickly fill up with auto-generated styles - stylel, style2, style3 and so on.
Expression Web can help with this issue by automatically reusing styles with the same
properties where possible.

Example: Create a short paragraph of text (one line) and apply underline to the text. The
following will be added to your <p> tag class="auto-style1l" and the associated style block would
be added to the head section of your page:

<style type="text/css"> .auto-stylel { text-decoration: underline; } </style>

If you then change the text color of this paragraph to #CC3300, then EW would just update
stylel accordingly.

<style type="text/css"> .auto-stylel { text-decoration: underline; color: #CC3300; } </style>

If you then add a second paragraph of underlined text, style2 would be created in the head
section and applied to the paragraph.

.auto-style2 { text-decoration: underline; }

If you then apply the same color #CC3300 to that paragraph, both paragraphs would be
updated to use the same style — stylel — and style2 would be deleted.

If you see a lot of stylel, style2, etc in the head section of your page, please read What are all
the style# in my page?

Tools > Page Editor Options > Authoring Tab
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Page Editor Options llléj

| General I AutoThumbnail | Default Fonts | Code Formatting i CSs I Color Coding
AUthUri”QN Picture | Code Snippets | Ruler and Grid | IntelliSense | Font Families

Mews Docu Its
Choose the default type of new documents and the default file extension of new
HTML documents.
Default Document: Add a byte order mark (BOM) when
HTML = creating or renaming UTF-8 documents
with these file extensions
Default HTML File Extension: [ |-htm []s
@ html i [7.php
5 | |.css ot
() .htm Ldwit [_.xml

Doctype and Secondary Schema

Choose the doctype declaration to be inserted into new pages. A matching document
schema will be used to drive incompatibility notifications and IntelliSense for HTML
and script. If a page has no doctype or an unrecognized doctype is declared, the
Secondary Schema will be used.

Document Type Declaration: Secondary Schema:
XHTML 1.0 Transitional - [mnternet Explorer 8.0 =
CS5 Schema

This schema determines what is available in CSS IntelliSense.
Schema version:
C55.2.1 -

OK l ’ Cancel

Figure 33: : Page Editor Options > Authoring Tab

For New Documents:

e Tick your default file extension .htm or .html. It does not matter which one you choose, just be
consistent. See warning below.

e Adding a BOM on PHP pages causes problems because it will appear on the webpage disrupting
the display. Introduced in EW 2.0 and available in EW 4.0 is the ability to turn off the addition of
a byte order mark in UTF-8 pages by file extension. By default, only the .php extension has the

BOM turned off. | turn it off on all pages. | do so by clearing the checkmark from each the file
extensions listed.

EW 3.0 and 4.0 .htm bug

WARNING: If you choose to use the .htm file extension, be aware that there is a bugin
Expression Web 3.0 and 4.0. If you use any of the generic site templates that ship with
Expression Web or any third party Site Templates to create your website, and have selected the
.htm file extension, you will see before your eyes the index.html page change to default.html.

If you blink, you may miss this. This is a little known bug.

If you have it set the default extension to .html then your homepage extension will remain
index.html. You can, of course, rename your homepage file to whatever your host requires by
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right clicking on the selected link in Folder List View (Panels - Folder List or Alt + F1) and
choosing 'Rename’.

EW 4.0 .htm bug

WARNING - This bug affects Expression Web 4.0 ONLY but is a more serious bug than the one
mentioned above.

If you download and install any third party .tem Site Template package such as those offered by
Migrating from FrontPage to Expression Web and at the same time have your default page
extension set to .htm, you will see the following behavior:

1. RENAMIE the first file in the list of files, from whatever it is named to default.html
2. Adialog box will appear (see Figure 35: Replace file message) asking "A file with the name
default.htm already exists. Do you want to replace this with your file?"

1. If you say YES, then EW 4.0 will proceed to delete the next file in the Folder List. It will
continue to do this each time you say yes, till all that is left is the changed default.html
which is now your homepage.

2. If yousay NO, then it will ask for each file in the list, till it has worked through them all,
however the file renamed to default.html remains and is now your homepage.

Microsoft Expression Web lihj

o A file with the name default.htm already exists.

Do you want to replace this with your file?

Figure 34: Replace file message

Until this bug is fixed, | would strongly suggest choosing .html as the default file extension. That
choice will affect all new files. Old files will remain untouched and you can always rename the
file to use the .htm extension if you so choose.

NOTE: This bug has NOT been corrected with the release of Service Pack 2. It has also NOT been
fixed in the free version of Expression Web.

Doctype and Secondary Schema

The default settings are:

e Document Type Declaration - XHTML 1.0 Transitional
e Secondary Schema - Internet Explorer 8.0

Expression Web 4.0 Tutorials from Install to Publish and More Page 41


http://www.frontpage-to-expression.com/site-templates/

CSS Schema

The default setting is:

e (CSSSchema:-CSS2.1

Tools > Page Editor Options > Intellisense Tab

Page Editor Options @I&J

General | AutoThumbnail | Default Fonts | Code Formatting | CSS I Color Coding
Authoring | Picture | Code Snippets | Ruler and Grid | IntelliSense ‘ Font Families

The following settings are for the Code pane only.

Auto Popup
[V]HTML statement completion [¥] FHP global variable completion
[#] css statement completion [#] PHP parameter information
[¥] ASP.NET statement completion Enable the following PHP function categories:
[/] Scripting statement completion /] Apache -
V| Array =
[¥] script parameter information I/ |BCMath =
/| Calendar
|| Character type
/| CcuRL
| Database abstraction layer ™
Auto Insert
[¥] Close tag

[¥]HTML attribute value quotes

[¥]%SLT attribute value quotes

[/] ASP.NET attribute value quotes

|] cS5 selector closing brace

Code Hyperlinks

[#] Enable Code Hyperlinks for the following elements:
[#] css classes and s
[¥] Script functions
[¥] Document hyperlinks

0K l I Cancel

Figure 35: Page Editor Options > Intellisense Tab

Tick all the boxes provided. Intellisense works in Code View and allows you to look up and insert
code that's compatible at the place in your code where your cursor is currently located.

In Code View, place your cursor where you want the tag and type the opening <. When the
Intellisense menu pops up, scroll to the entry you want. You can press Enter or double-click to
insert it. Intellisense is also available when you are editing an existing tag or from the Quick Tag
bar.

Intellisense can also be using while working with CSS.

IntelliSense provides:
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e Auto-insertion of end tags, end braces, and value quotes.

e Context-sensitive shortcut menus that list and can insert code that is compatible at the current
point in the code.

e Context-sensitive ScreenTips that list variables, functions, or parameters that are compatible at
the current point in the code.

e Code hyperlinks, which enable you to click hyperlinks or references to classes, external CSS files,
and script functions to open or go to the source of these items.

The DocType declaration in a page determines the options that appear in the IntelliSense
shortcut menus in the Code view of a page.

As an example: If you are using the default doctype declaration XHTML 1.1, Expression Web will
NOT offer the target attribute as it has been deprecated in XHTML.

In addition, the option you set for the CSS Schema in the Page Editor Options dialog box
determines the level of CSS that appears in IntelliSense shortcut menus.

There are other tabs you can explore under the Page Editor Options settings, but the ones listed
above are the main ones. For greater detail, download Setting Up Expression Web 4 by Tina
Clarke.
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Create New Website in Expression Web 4.0

NOTE: There are some major changes in the User Interface of Expression Web 3.0 and 4.0
from previous versions. Many of the items to manage your site are now located on the Site
Menu list.

|5ite Data View Panels WebAssist Window Help

] New Site... Ctrl+5Shift+N
* Open Site... L Ctrl+Shift+0
Recent Sites r
Close
Publishing

Publishing Settings...

{5 Publish Changed Files to "Expression Web Tutorials & Templates” Ctrl+Shift+H
(% Publish All Files to "Expression Web Tutorials & Templates” Ctrl+Shift+A

Delete...
Export to Web Package...
Import L

Manage Sites List...
Site Settings...

Figure 36 - Site Menu

Now that you have Expression Web 4.0 installed and you have set up the program following the
Setting Up Expression Web tutorials and Tina’s FREE EBook, you are ready to start working on
your new web. If you have already created a website you can open it in Expression Web. There
is no need to import the site. Be sure you have a good backup just in case.

WARNING: If your current website is using the Shared Borders feature of FrontPage DO NOT
OPEN THE SITE in Expression Web 4.0 without first removing the shared borders. WHY?
Because Expression Web corrupts the feature and replicates the shared borders. For more
details see How Expression Web 4 treats Shared Borders.

Or you can create a new website and start from scratch. NOTE: Screen shots may look different
from what you see. | am running Expression Web 4.0 on a computer with Windows Vista
Ultimate installed.

Create a One Page Website

Step 1: Start Expression Web > Site > New Site.
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il Data View Panels  Wing

| New Site.., D}

%< Open Site...
Recent Sites L4

Close
Figure 37 - New Site
Step 2: In the dialog box

1. Choose General > One Page Web Site >

2. Under specify location of the new website, place your cursor in the box and delete from
the right end up to the slash after MY WEB SITES\ or you can browse to the location
where you want the new web created. Type in the name of your website — use a
hyphen rather than an underscore. | use the actual name of my domain as the folder
name, without the extension. Example: expression-web-tutorials.

3. Tick the box if you want this site added to your Manage Sites Listing and specify the
Name of your site. The default is the name you type in the location box, BUT you can
change it to include CAPS and spaces, i.e., Expression Web Tutorials.

4. Click OK.

New : B |
ste |
] [— | One Page web Site Description [
| __J Empty Web Site Create a new Web site with a single blank
. e Wi page.
|| |empiates «J Import Web Site Wizard
i
| |_
\
Options
|| Add to current site
Specify the name and location of the new site
(1003“0”3 C:\Users\Patridia Geary'\Documents\My Web Sites\expression-web-tutorials ) T | Browse... |
CJ Add to Managed List Name: |Expression Web Tutorials )
Ul | oK Cancel

Figure 38 - New Site Dialog

Step 3: The new website will be created with one page named default.html. | immediately
rename it to index.html by right clicking on the file (from the Folder List Task Panel) > Rename.
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Open With 3

New From Existing Page

;T'. Display in SuperPreview
& 1 Moxzilla Firefox 36.6

Preview in Multiple Browsers

b Cut
=3 Copy

Set as Home Page
Rename E}
X Delete

Publish Selected Files to "Expression Web Tutorials & Templates”

Exclude from Publishing

Properties...

Figure 39 - Rename

Step 4: Use this for your new website. At the same time, | create a new folder for images.

Either click the new folder icon, : OR Right Click > New > Folder > type images.

New Folder icon

Figure 40 - New Folder Icon
The default doctype used in Expression Web is:

<IDOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.0rg/TR/xhtml|1/DTD/xhtml1-
transitional.dtd"> <html xmlIns="http://www.w3.0rg/1999/xhtml">

You can change that in Tools > Page Editor Options > Authoring.

Now that you have created your website, you can either open the default.html, or index.html if
you renamed it, and begin creating a page that will serve as the template for your site.

If you would like a starting point for designing your new website, please feel free to download
and use one of these FREE CSS based layout templates available from Genealogy Web Creations
or import one of the Personal Web Packages from Expression Web Tutorials & Templates.

You might also consider downloading and installing one or all of the FREE Expression Web Site
Template sets. There are four different layout sets available as well as some equal height
column templates.
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Cheryl Wise also has a selection of templates you may choose to use.

| would encourage you to start from scratch if you are starting out with the program.
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Create a Blank Web Page

Now that you have actually created your website, you will need to create your Home Page. If
you created a one page website, your Home Page was created at that time. If you created a
blank website, you will need to create a Home Page for the site.

Expression Web 4.0 can create various types of pages, BUT in this tutorial we will create an
HTML page and its corresponding style sheet. Types of pages that can be created include:

e HTML
e ASPX
« ASP
« PHP
. CSS

e Master Page

e Dynamic Web Template
e Javascript

e XML

e Text File

Create a Blank Web Page

Step 1: There are a number of ways for you to create your new page:

e Ctrl+N

e File > New > HTML

e Click File > New > Page > General > HTML.

e Click the New Document dropdown from the Common or Standard Toolbar > select
HTML.

If you click the Code Tab and view the page source, you should see something like what is
below.

<IDOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.0rg/TR/xhtml|1/DTD/xhtml1-
transitional.dtd">

<html xmIns="http://www.w3.0rg/1999/xhtml">

<head>

<meta content="text/html; charset=utf-8" http-equiv="Content-Type" />

<title>Untitled 1</title>

</head>

<body>

</body>

</html>
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Step 2: Depending on what you chose as your default extension, when you set up EW 4.0, your
newly created page has the file name Untitled_1.html or Untitled_1.htm. You will need to save
the page.

Saving the Page

Step 3: There are a number of ways to save your pages:

o Ctrl+S

e Right Click the page tab. > Select Save.

e Click File > Save.

e Click the Save Icon on the Common or Standard Toolbar.

In the dialog box that opens, 'file name' will be highlighted. > Type 'index,' > press the Enter key

OR click 'Save.' It is not necessary to add the file extension .htm or .html. Expression Web will
do it for you. Your page has been saved, and you are ready to add the external style sheet.

Create an External Style Sheet (CSS)

Step 4: There are a number of ways to create your new style sheet.

e File > New > CSS

e Click File > New > Page > General > CSS.

e Click the New Document dropdown from the Common or Standard Toolbar. > Select
CSS.

Step 5: Save the page as you did, following the choices in Step 3. Type a name for the style
sheet. Expression Web will add the file extension for you.

Attach the External Style Sheet to the Page

Step 6: As with many things you do in Expression Web, there is more than one way to
accomplish a task. To attach the external style sheet to the page:

e With the webpage open in Design view, drag the .css file from either the Folder List
panel or the Site View onto the page.
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In the Manage Styles Panel or the Apply Styles Panel, click on 'Attach Style Sheet.
Apply Styles ~ Manage Styles * B’ x

Figure 41 — Manage Styles > Attach Style Sheet

o Browse to your style sheet in the popup box.
o Attach To: Check 'Current page.'
o Attach As: Check 'Link.'
o Click OK.

Attach Style Sheet (2] = )

URL: sample.css

Attach to: () All HTML pages  Attach as: (@) Link

Selected page(s) () Import

(@) Current page

0K ] l Cancel

Figure 42 - Attach Style Sheet

If you click the Code Tab and view the page source, you should see a line of code has been
added to your page with the name of your style sheet.

<link href="sample.css" rel="stylesheet" type="text/css" />

Summary

You have now created your Home Page and the external style sheet and attached the style
sheet to your page. The next step is to create the layout for your page.

You could use one of the premade templates that come with Expression Web or you could
choose to download and use one of these FREE CSS-based layout templates available from
Genealogy Web Creations or import one of the Personal Web Packages from Expression Web
Tutorials and Templates OR you can create a basic layout from scratch as the next tutorial will
guide you through.

Expression Web supports Dynamic Web Templates as a way to maintain a consistent look to
your site. The page we are creating will be the basis for a DWT for your site. Tina Clarke offers
free the Expression Web DWT EBook. This is an excellent resource, so be sure and take
advantage of this free download.
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Create a Webpage Layout in Expression Web

Before you proceed with creating your webpage layout, you should have spent some time
actually thinking about the content and the design you want to use to present that content.

The content, after all, is what is going to draw viewers to your site. You need to decide on the
best way to present that content so your viewers linger longer.

While you can certainly design your layout on the computer, it might be easier to just use a
paper and pencil and draw out a rough layout of how to best present your content.

Your layout will probably include a masthead or banner at the top, perhaps a top navigation
menu, a content area that may include multiple columns, and footer at the bottom of the page.

In the past, you may have used tables to achieve this look. Tables created an assortment of
boxes that were used to create rows and columns. Now web designers use <div>s to form the
boxes and CSS to place those boxes on the page.

For this tutorial, we will be using <div></div> tags to create the various boxes and style rules to

place those boxes as a two column layout with masthead, top navigation bar, left sidebar, main
content area, and footer. Each of the boxes or divs will hold the content for your page.

What is a <div> tag?

The <div> tag defines a division or section in a page and makes it easy to manage, style, and
manipulate those divisions or sections. Browsers usually place a line break before and after the
div element. Use the <div> tag to group block-elements to format them with styles.

container

masthead

top-nav

< ao0uUT

left-nav main-content

body

Figure 43 - Layout example
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The layout shown in Figure 44 shows the use of div tags. Each div tag <div></div> creates a
box. Using various style rules, the boxes will be positioned to create the layout used in this
tutorial. Once you learn the basics of working with div’s you can create one, two, or three
columned layouts. Read more on the HTML <div> tag. What are block-level elements?

Create the Layout

| would recommend working in 'Split View' rather than ‘Code View’ or 'Design View' so that
you see the results of actions you take. Before we start, make sure your 'Toolbox panel' is
available. Click Panels > Toolbox. The default location is on the right-hand side of your editing
window. You can move it wherever you like.

| Untiied 1 (G MY Wi 50 Wicromch Dxpression Wee = e
File Edn Wi mat Took Table 5

oo - N CEST CIE 0c  BBEEEd CEas O-2-M-m-ERs
HEEGeESEEN- L - H-wF LK B A-e22000

1 - The menus and toolbars let you perform tasks such saving files and sites,
generating reports, and changing how you view a page.

2 - Panels let you perform common tasks, such as managing files in a site, adding
tags to a page, and managing styles.

3 - The editing window lets you visually edit pages or directly edit page markup.
4 - The status bar shows you important information about sites and pages.

Toolbox Panel - default location is on the right of
the editing window.

Figure 44 - Expression Web 4.0 Workspace

As we create the layout for our page, we will also be adding the style rules to our external style
sheet. NOTE: When you select 'Preview in Browser,' the last browser you used will be what
opens your next preview with. You should view your pages as you develop them in BOTH
Internet Explorer and Firefox and at more than one resolution. Not everyone is going to view
your page with their browser open fullscreen or have the latest and greatest in monitors.

Expression Web 4 offers two additional ways to preview your pages — 'SuperPreview' or the
'Snapshot' panel. To use the 'Snapshot' panel, click Panels > Snapshot. To view your pages with
'SuperPreview,' select File > Display in SuperPreview OR Press Shift + F12.

If it is not already open, open the page you created earlier in Expression Web. File > Open OR
Press Ctrl + O.
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Style the <body> tag

The body element defines the document’s body. To style the <body> tag, create a new style.
From the 'Manage Styles' or 'Apply Styles' panel click 'New Style.' In the New Style dialog box,
type or select the following:

Selector: Choose body from the dropdown list.

Define in: select ‘Existing style sheet’ from the dropdown. Select the style sheet.

Font: Set the font-family and color.

Background: Set your page background color. You may also choose to use a seamless

background as the page background.

5. Box: Set the margins and padding to Opx, which remove the default margins web browsers apply
to a web page.

6. Click OK. Save your page and view in your browser.

7. Atthe same time, copy and paste the following to your style sheet: body img { border: Opx; text-

decoration: none; }, which will keep any images that are hyperlinks from having the ugly blue

border.

PwNE

You can also use the ‘CSS Properties’ task panel for creating styles.

Add the Container

The first <div> we will add will be for the container that will "hold" all of the other <div>’s or
elements of our page. Style rules will be added as we add the <div> tags.

Step 1: With your page open in 'Split View,' drag the <div> from the 'Toolbox' panel and drop it
on your open page. You will see that <div></div> has been added to your page.

Step 2: Using the 'Quick Tag Selector,’ click <div>. From the 'Manage Styles' or 'Apply Styles'
panel click 'New Style.' In the New Style dialog box, type or select the following:

Site View  index.html =

Quick Tag Selector
SB00y] <ivconvner> [ SaEmasheads] <

Figure 45 - Screenshot Quick Tag Selector
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Figure 46 - Screenshot New Style Panel

1. Selector: #container (the hash mark # is an ID selector). NOTE: You can NOT select container
from the dropdown list. You will need to actually type in #container in the selector box.
Define in: select Existing style sheet from the dropdown.

Check: Apply new style to document selection.

URL: Browse to your style sheet that you created and attached in the previous tutorial.

Background: Set the background color #FFFFFF (white.) NOTE: Using a light color for the

container background will allow your text to be more easily read.

6. Click the Position Category in the Style Builder. Set it to 80% for the width. Do NOT specify a
height so that the container can expand as you enter content.

7. Click on the Box Category. Set the right and left margins to 'auto,' and top and bottom to
10px. Set the padding to 10px. NOTE: setting the left and right margins to auto, will center the
container on the page.

8. Click OK.

vk wnN

Your style sheet now contains the following:

#container { width: 80%; padding: 10px; margin: 10px auto 10px auto; background-color: #FFFFFF; }

and your html code contains
<div id="container"> </div>.

NOTE: Setting the width to a percentage, will allow the container to fill 80% of the viewer’s browser
window NO MATTER what the size of the window is. That means if your viewer has a 15 inch laptop
screen, the container will fill 80% of the available real estate. By the same token, if your viewer has a
snazzy new 24 or 27 inch monitor, the container will fill 80% of the allowable screen space. You may
choose to specify a maximum width for the container. More on CSS max-width Property.
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Add the masthead and style rules

1. Click and drag a <div> from the Toolbox onto the page, making sure it is INSIDE the container
<div>. NOTE: If you have a hard time doing this, in code view, place your cursor between the
opening and closing <div> tags, switch to the design window, and then drag your new <div> into
the container.

2. Click 'New Style.' Check: Apply new style to document selection.

3. Selector: #masthead NOTE: You can NOT select masthead from the dropdown list. You will need
to actually type in #masthead in the selector box.

4. Click the Position Category: set the height to 170px. Do not set a width. This will allow the
header to extend across the entire width of the container.

5. Click on the Background Category and set a background color and image if you choose to use
one.

6. Click OK. Save your page and view in your browser.

Your style sheet now contains the following:

#masthead { background-color: #54B431; background-image: url ('clover-bg.jpg'); background-repeat: no-repeat;
background-position: right center; height: 170px; }

and your html code contains

<div id="container">
<div id="masthead"> </div>
</div>

Add the Top Navigation and style rules

1. Click and drag a <div> from the Toolbox onto the page making sure it is INSIDE the container
<div> and BELOW the masthead <div>.

2. Click 'New Style.' Check Apply new style to document selection.

3. Selector: #top-nav NOTE: You can NOT select top-nav from the dropdown list. You will need to
actually type in #top-nav in the selector box.

4. Position: set the height to 50px. Do not set a width. This will allow the menu to extend across

the entire width of the container. NOTE: Additional style rules will be added later.

Border: Set the top and bottom borders.

Background: Set the background color.

Click OK. Save your page and view in your browser.

Menus are best suited to unordered lists. Additional style rules will need to be set for your top

navigation.

o N WU

Your style sheet now contains the following:

#top-nav { height: 50px; border-top: solid medium #006600; border-bottom: solid medium #006600; background-
color: #FFFFFF; }

and your html code contains
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<div id="container">

<div id="masthead"> </div>
<div id="top-nav"> </div>
</div>

Figure 47 - Screenshot of Layout

Add and style the Columns

Our sample page will consist of two columns — one on the left for additional navigation or
messages and the main column for content. We will float the one column to the left and place
the main content area by applying a left margin.

Step 1: Insert the left column

1. Click and drag a <div> from the Toolbox onto the page making sure it is INSIDE the container
<div> and BELOW the top-nav <div>.

2. Click 'New Style.' Check: Apply new style to document selection.

3. Selector: #left-nav NOTE: You can NOT select left-nav from the dropdown list. You will need to
actually type in #left-nav in the selector box.

4. Position: set the width to 180px. Again, do not set a height so the column will expand as you
add content.

5. Layout: float: left. hic. If you do not specify the background color, the container will be seen.

6. Border: Add a border to this container if you wish.

7. Box: Set the top margin at 20px and the bottom margin at 10px. Set the left and right margins as
Opx. This will push the top of the left side column down from the border of the top navigation.

8. Click OK. Save your page and view in your browser.

9. Menus are best suited to unordered lists. Additional style rules will need to be set for your left
navigation.

Your style sheet now contains the following:

#left-nav { margin: 20px Opx 10px Opx; width: 180px; float: left; border: thin dashed #006600; }

and your html code contains

<div id="container">
<div id="masthead"> </div>
<div id="top-nav"> </div>
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<div id="left-nav"> </div>

</div>

Step 2: Insert the Right or Main Content Column

Click and drag a <div> from the Toolbox onto the page making sure it is INSIDE the container
<div> and BELOW the left-nav <div>.

Click 'New Style.' Check Apply new style to document selection.

Selector: #main-content NOTE: You can NOT select main-content from the dropdown list. You
will need to actually type in #main-content in the selector box.

Background: Add a background color or a graphic. If you do not specify the background color,
the color will be the same as specified in the container.

Border: Add a border to this container if you wish.

Box: Set the top margin at 20px and the left margin at 200px, right margin to 10px, and bottom
margin at 10px. This will push the main content down from the border of the top navigation and
to the right of the left navigation <div>.

Click OK. Save your page and view in your browser.

Your style sheet now contains the following:

#main-content { margin: 20px 10px 10px 200px; background-color: #CCFFCC; }

e Y‘"«VE_[_

Figure 48 - Screenshot of Layout after content added

and your html code contains

<div id="container">

<div id="masthead"> </div>

<divid=

"top-nav"> </div>

<div id="left-nav"> </div>

<div id="main-content"> </div>

</div>

Add and style the Footer

1.

2.

Click and drag a <div> from the Toolbox onto the page making sure it is INSIDE the container
<div> and BELOW BOTH column <div>'s.
Click 'New Style.' Check: Apply new style to document selection.

Expression Web 4.0 Tutorials from Install to Publish and More Page 57



3. Selector: #footer NOTE: You can NOT select footer from the dropdown list. You will need to
actually type in #footer in the selector box.

4. Border: Add a top border to this container if you wish.

5. Layout: clear: both — this will clear the float that was used to position the column and push the
footer below BOTH of the columns.

6. Block: text-align: center

7. Box: Add padding of 10px to the top and bottom.

8. lalso add the following style rule to the footer: id #footer p { margin-top: Opx; margin-bottom:
Opx;}. This allows for the use of the <p> tag in entering the information for your footer but
removes the top and bottom margins of the paragraphs.

9. Click OK. Save the page and view in your browser.

Your style sheet now contains the following:

#footer { border-top: 2px solid #006600; clear: both; padding: 10px Opx; text-align: center; }
#footer p { margin-top: Opx; margin-bottom: Opx; }

and your html code contains

<div id="container">

<div id="masthead"> </div>
<div id="top-nav"> </div>

<div id="left-nav"> </div>

<div id="main-content"> </div>
<div id="footer"> </div>

</div>

CONTAINER

top-nav

left-nav main-content

AMzZ->-4Z00

footer

Figure 49 - Screenshot of basic layout with <div>'s identified

Adding Meta Tags

Your page currently contains these meta tags in the head section:

<meta content="text/html; charset=utf-8" http-equiv="Content-Type" />
<title>Sample Site</title>

You will need to add additional meta tags to the head section of your page.
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<meta name="keywords" content="" />

<meta name="description" content="" />

<meta content="en-us" http-equiv="Content-Language" />

<meta content="General" name="rating" />

<meta content="Copyright © 2008-2012, You Name or Business All Rights Reserved" name="copyright" />

Right click in Design View on your page > Page Properties.

e General Tab
o Title: Type the title for your page.
o Page description: Type a brief description of what your page is about.
0 Keywords: Type the keywords for your page separated by commas.
e Custom Tab (Can be used to add meta tags)
o Click Add >
0 Name: Type copyright.
0 Value: Type Copyright © 2008-2012, You Name or Business All Rights Reserved.
o Click OK.

OR you can copy and paste the tags into your document. Read more on Basic Meta Tags

Summary

You have now completed the basic layout of your page. Additional style rules will need to be
added for your menus, your heading tags, and floats for your images. You can test how your
page layout will look by adding some filler content. Some of the style rules will need to be
modified. E.g., adding padding to the main content area and the left navigation container.

NEXT: Adding Navigation to the Layout. This will be done in two parts. We will add a horizontal
top menu, then a left-side navigation menu.
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Adding Horizontal Top Navigation to Webpage
Layout

Now that you have created a basic layout for your webpage, it is time to add some navigation
to it. First, | will show you how to add a horizontal menu for your top navigation. In a separate
tutorial we will add a vertical menu on the left.

Add and style the top menu

As you develop your menu, make sure you preview it in both Internet Explorer and Firefox. You
will also need to check it at various resolutions to make sure you do not add too many links to
the menu. You might try viewing it using the new 'SuperPreview' feature.

Create the menu list

Create a simple bulleted list for your top menu. Remember you are going to be limited on the number of
items to include so that your menu will not "break” when resized. In 'Design’ or 'Code' view, in your
webpage, place your cursor where you want to create a list, and then do one of the following:

=

e On the 'Common' toolbar, click Bullets _, or on the 'Formatting' toolbar, click the Style box,
and select Unordered List.

e Dragthe page you want to include as a menu item from the 'Folder List' panel to the first bullet.
Hit 'Enter' to add a new list item. Using this method will create your hyperlinks as you go along.
If you have no pages as part of your website but would like to create the menu items and pages
as you go, you can follow Creating a New Page from Hyperlink Properties.

e OR for each item or line of text that you want in the list, type the text, and then press ENTER to
add a bullet to the list. If you use this method, you will need to create the hyperlinks to the
menu items.

To create or modify a hyperlink

e Inyour webpage, in 'Design’' view or 'Code’ view, do one of the following:

e Select the item that you want to use as the hyperlink >. Press Ctrl + K OR right click and select
hyperlink.

e ORIn either the 'Common' or the 'Standard’ toolbar, click Insert Hyperlink.

e Inthe 'Insert' or 'Edit' Hyperlink dialog box, do the following:

e Text to display: Type the text you want to display as the menu item.
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e Existing File or Webpage: In the Address box, browse to the file you want to link to OR Copy and
Paste the URL of the webpage you wish to link to.

Edit Hyperlink 2l =

Uink to Text to display: Home ScreenTip...

]
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Figure 50 - Edit Hyperlink Dialog Box

e Click 'Screen Tip,' Type a brief description of the link. For SEO purposes, use the title of the
page. Warning: Expression Web 4.0 has a bug that causes EW to lose focus when adding the
Screen Tip via the hyperlinks dialog box. As soon as you type the text you want and click OK, EW
will switch to the last open window. You will need to go back to Expression Web in order to
complete the process. NOTE: This bug appears to have been fixed with the release of SP1 and
SP2.

( Set Hyperlink ScreenTip |M

-

ScreenTip text:

Home - Site Name.

Mote: Custom ScreenTips are supported in Microsoft® Internet
Explorer@® version 4 or later.

0K l l Cancel

Figure 51 - Set Hyperlink Screen Tip

e Continue this procedure until you have added all of your top menu links.

If you view your source code, it should look something like the following:

<ul>

<li><a title="Home - Site Name." href="index-two.html|">Home</a></li>
<li><a title="Menu Item." href="index.htm|">Menu Item</a></li>
<li><a title="Menu Item." href="index.htm|">Menu Item</a></li>
<li><a title="Menu Item." href="index.htm|">Menu Item</a></li>
<li><a title="Menu Item." href="index.htm|">Menu ltem</a></li>
<li><a title="Menu Item." href="index.htm|">Menu ltem</a></li>
<li><a title="Menu Item." href="index.htm|">Menu ltem</a></li>
<li><a title="Menu Item." href="index.htm|">Menu Item</a></li>

</ul>

Of course, each menu item would hyperlink to its own page NOT the index.html page. This is
just an example.
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Adding styles to the menu

Open your index.html page in 'Design' view.
From the 'Manage Styles' panel > right click #top-nav > Modify Style.

(o}
(o}
(o}

Select the ‘Position’ Category and REMOVE 50 from height.
Select the 'Border' Category and change the width to thin.
Select the 'Box' Category and uncheck padding: Same for all > top: 10px bottom: 10px.

From the 'Manage Styles' or 'Apply Styles' panel click 'New Style'. In the New Style dialog box,
type or select the following:

(o}
(o}
(o}
(o}

(o}

Selector: #top-nav ul NOTE: You can NOT select top-nav ul from the dropdown list. You
will need to actually type in # top-nav ul in the selector box.

Define in: select Existing style sheet from the dropdown. Select the style sheet.

Block: text-align: center

List: list-style-type: none

Box: margin: Opx; padding: Opx

From the 'Manage Styles' or 'Apply Styles' Panel click 'New Style.' In the New Style dialog box,
type or select the following:

(o}

(o}
(o}

Selector: #top-nav ul li NOTE: You can NOT select top-nav ul li from the dropdown list.
You will need to actually type in # top-nav ul li in the selector box.

Define in: select Existing style sheet from the dropdown. Select the style sheet.
Layout: display: inline

From the 'Manage Styles' or 'Apply Styles' panel click 'New Style'. In the New Style dialog box,
type or select the following:

(o}
(o}
(o}
(o}

(0]

Selector: #top-nav ul li a NOTE: You can NOT select top-nav ul li afrom the dropdown
list. You will need to actually type in # top-nav ul li a in the selector box.

Define in: select Existing style sheet from the dropdown. Select the style sheet.

Font: color: #ffffff

Background: background-color: #006600

Box: untick padding: Same for all > top and bottom .2em > right and left 1em

From the 'Manage Styles' or 'Apply Styles' Panel click 'New Style'. In the New Style dialog box,
type or select the following:

(o}

O O o oo

Selector: #top-nav ul li a:hover NOTE: You can NOT select top-nav ul li a:hover from the
dropdown list. You will need to actually type in # top-nav ul li a:hover in the selector
box.

Define in: select Existing style sheet from the dropdown. Select the style sheet.

Font: color: #000000

Background: background-color: #CCFFCC

Border: border: 1px #99BF99 solid;

Expression Web 4.0 Tutorials from Install to Publish and More Page 62



e Save your page and Preview in Browser.

- X -

seneanvenenatis, | YOUr Heading Tag would go here.
urna et ultricies
ullamcorper, mauris
nulla rutrum umna, nec
wvehicula orci neque
eget quam. Proin sem
leo, pulvinar id gravida
aat

Agnean venenatis, urna et ultricies ullameorper, mauris nulla rutrum uma, nec
vehicula orci neque eget quam. Proin sem leo, pulvinar id gravida non,
pharetra at arcu. Morbi vitae mi ut massa tincidunt placerat. Quisque quis dul
sem, non venenatis nunc. Aenean in erat et arcu facilisis cursus! Nam lacinia
massa a tellus fringllla id euismod nis! tincidunt. Pellentesque habitant morbi
ACU tristique senectus et netus et malesuada fames ac turpis egestas. Ut a turpis at

Machi witae mi 1t

Figure 52 - Page Previewed in Browser

Converting Your Menus to Include Pages

You may wish to use different menus for different sections of your site. Rather than have the menu as
part of your DWT, you can create an include page or pages that can be inserted in the menu region. As
an example, my main site Expression Web Tutorials & Templates uses one menu for the main pages and

a separate menu for the tutorials section. If | need to make a change to the menu, | edit the include page
which will then update each page the include is part of. You can use more than one include on a page
and includes can be nested.

When the Design Time include is added to your final page, only the content between the <body> and
</body> tags is included. Any styles you create as part of the include page must be part of the external
style sheet or they will not be applied.

You can read more about Expression Web and Design Time Includes

Creating the include page
It is a good idea to save all your include files in a single folder and to give them a name which makes
their function obvious.

Create a new folder for the includes. Click 'Site View' tab, > Click 'New Folder' icon. :> Type _includes
as the name of the folder.

e Click the 'New Document' icon. Save the page with the name top-menu.html in the _includes
folder.
e Copy and Paste the menu list from your index.html page into the new top-menu.html page.
Delete the menu list from your index.html page.
e Place your cursor where you wish the include file to appear. Click the include page icon on the
standard toolbar (pictured below) OR use the Code Snippet to insert the include page.
0 Using Code Snippets to Insert Include Pages
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0 Use the 'Standard Toolbar' to insert your include page

Include Page..

Figure 53 - Standard Toolbar

¢ Inthe ‘Include Page Properties’ dialog box, browse to the location of your include page > Click
OK.

Include Page Properties @éj

Page to include:

includes/top-menu.html

o ][ concal |

e o

Figure 54 - Include Page Properties dialog box

e The include page will be inserted into your page and you will see the following in Code View.
<div id="top-nav"><!--webbot bot="Include" u-include="_includes/top-menu.html" tag="BODY" --></div>
e Preview your page in the browser and you will see your menu has been inserted within the

page.

If you need more detailed instructions, you can follow the tutorial Expression Web and Design Time

Includes.

Navigation Resources

e Website Navigation - Website Navigation Structure
e Navigation Menu - Creating A Navigation Menu
e Website Navigation

Whatever your final choice of navigation is, it should be a consistent navigation scheme from
page to page throughout your site. This helps the website visitor learn your website navigation
system.

CSS Menu Resources

e CSS Library Horizontal CSS Menus
e CSS Library Vertical CSS Menus

e (CSS Play Menus
e CSS MenuMaker
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e CSS Express Drop-Down Menus - by the folks at ProjectSeven. This is my absolute favorite for a
CSS dropdown menu.

You will also need to make sure that whichever menu system you use, that it renders in all
browsers.
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Adding Vertical Navigation to Webpage Layout

Now that you have created a basic layout for your webpage, it is time to add some navigation
to it. In the previous tutorial | showed you how to add a top navigation menu. This time we’ll
work on a vertical menu.

Add and style the left side menu

As you develop your menu, make sure you preview it in both Internet Explorer and Firefox. You
will also need to check it at various resolutions to make sure it continues to work as you expect
it to. Or you can use the new 'SuperPreview' — Shift + F12.This menu is based on the Urban
Grey Side Menu from Dynamic Drive.

Create the menu list

Create a simple bulleted list for your left-side menu. The list can be separated into sections by adding a
<p></p> tag before starting each list. In 'Design' or 'Code' view, in your webpage, place your cursor
where you want to create a list (between the <div id="Ileft-nav"></div> tags, and then do one of the
following:

¢ Type a Section heading like Site Navigation BEFORE you start your list.

e Onthe 'Common' toolbar, click Bullets ===, or on the 'Formatting' toolbar, click the Style box,
and select Unordered List.

e Dragthe page you want to include as a menu item from the 'Folder List' panel to the first bullet.
Hit 'Enter' to add a new list item. Using this method will create your hyperlinks as you go along.
If you have no pages as part of your website but would like to create the menu items and pages
as you go, you can follow Creating a New Page from Hyperlink Properties.

e ORfor each item or line of text that you want in the list, type the text, and then press ENTER to
add a bullet to the list. If you use this method, you will need to create the hyperlinks to the
menu items.

To create or modify a hyperlink
In your webpage, in 'Design' view or 'Code' view, do one of the following:

e Select the item that you want to use as the hyperlink. > Press Ctrl + K OR right click and select
hyperlink.

¢ ORn either the 'Common' or the 'Standard' toolbar, click Insert Hyperlink

¢ Inthe 'Insert' or 'Edit' Hyperlink dialog box, do the following:
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0 Text to display: Type the text you want to display as the menu item.

o Existing File or Web Page: In the Address box, browse to the file you want to link to OR

Copy and Paste the URL of the webpage you

Edit Hyperlink

Link to: Tet to display:

@ .
Existing Flle or] %K™
Web Page
Current
Faider

&)

Document
Pages
i
Create New
Document

4l
E-mail
Address

Regent
Files

: Home Screentip..

Place in This @) index.html

Browsed | &, sample.css Parameters...

Address: .

¥

DIE
_ndudes Bookmark...

_vtienf
7 clover-bg.ipg Target Frome...

9

sample-site

\index.html [=] | RBemove Link

oK Cancel

Figure 55 - Edit

Hyperlink Dialog Box

wish to link to.

0 Click 'Screen Tip." Type a brief description of the link. For SEO purposes, use the title of
the page. Warning: Expression Web 4.0 has a bug that causes EW to lose focus when
adding the Screen Tip via the hyperlinks dialog box. As soon as you type the text you
want and click OK, EW will switch to the last open window. You will need to go back to

Expression Web in order to complete the process.

Set Hyperlink ScreenTip |??—

-

&3

ScreenTip text:
Home - Site Name.

Mote: Custom ScreenTips are supported in Microsoft® Internet
Explorer@® version 4 or later.

0K l l Cancel

Figure 56 - Set Hyperlink Screen Tip

e Continue this procedure until you have added all of your left side menu links.

If you view your source code, it should look something like the following:

<p>Site Navigation</p>
<ul>
<li><a title="Home - Site Name.

" href="index-two.html|">Home</a></li>

<li><a title="Menu Item." href="index.html|">Menu Item</a></li>

<li><a title="Menu ltem." href=
<li><a title="Menu Item." href=
<li><a title="Menu Item." href=
<li><a title="Menu Item." href=
<li><a title="Menu ltem." href=
<li><a title="Menu ltem." href=
</ul>

"index.html">Menu Item</a></li>
"index.html">Menu Item</a></li>
"index.html">Menu ltem</a></li>
"index.htm!">Menu ltem</a></li>
"index.html">Menu Item</a></li>
"index.html">Menu ltem</a></li>

Of course, each menu item would hyperlink to its own page NOT the index.html page. This is

just an example.
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Adding styles to the menu

Open your index.html page in 'Design' view.
From the 'Manage Styles' panel, right click #left-nav > Modify Style.

o Select the 'Box' Category, > Make sure padding: Same for all is ticked > 5px.

o Select the 'Font' Category: font-size: > 0.9em.
From the 'Manage Styles' or 'Apply Styles' panel, click 'New Style.' In the New Style dialog box,
type or select the following:

0 Selector: #left-nav ul NOTE: You will need to TYPE rather than select #left-nav ul

o Define in: select Existing style sheet from the dropdown. Select the style sheet.

o List: list-style-type: none

0 Box: margin: Opx; padding: Opx
From the 'Manage Styles' or 'Apply Styles' Panel click 'New Style'. In the New Style dialog box,
type or select the following:

0 Selector: #left-nav ul li : You will need to TYPE rather than select #left-nav ul li

o Define in: select Existing style sheet from the dropdown. Select the style sheet.

0 Box: untick padding: Same for all > bottom .2px
From the 'Manage Styles' or 'Apply Styles' panel click 'New Style.' In the New Style dialog box,
type or select the following:
Selector: #left-nav ul li a : NOTE: You will need to TYPE rather than select #left-nav ul li a
Define in: select Existing style sheet from the dropdown. Select the style sheet.
Font: color: #ffffff text decoration: none
Display: block
Background: background-color: #006600

o0 Box: untick padding: Same for all > top 5px right Opx bottom 5px left 8px.
From the 'Manage Styles' or 'Apply Styles' panel click 'New Style'. In the New Style dialog box,
type or select the following:

o Define in: select Existing style sheet from the dropdown. Select the style sheet.

o Selector: #left-nav ul li a:visited NOTE: You will need to TYPE rather than select #left-nav

ul li a:visited

o Font: color: #FFFF66
From the 'Manage Styles' or 'Apply Styles' panel click 'New Style.' In the New Style dialog box,
type or select the following:

o Define in: select Existing style sheet from the dropdown. Select the style sheet.

0 Selector: #left-nav ul li a:hover NOTE: You will need to TYPE rather than select #left-nav

ul li a:hover

o Font: color: #000000

0 Background: background-color: #006600
From the 'Manage Styles' or 'Apply Styles' panel click 'New Style.' In the New Style dialog box,
type or select the following:
Define in: select Existing style sheet from the dropdown. Select the style sheet.
Selector: Type #left-nav .headerbar
Font: color: #000000 font-size: 1em > text-transform: > uppercase
Layout: display: block
Background: background-color: > #CCFFCC
Padding: untick padding: Same for all > top and bottom 4px right and left 2px.

O O 0O o0 oo

O O 0O o0 O o

Expression Web 4.0 Tutorials from Install to Publish and More Page 68



e Save your page and Preview in Browser or use 'SuperPreview.'

e ‘. =

W &
— e~
Your Heading Tag would go here.
Aenean venenatis, urna et ultricies ullamcorper, mauris nulla rutrum urna, nec
vehicula orci neque eget quam. Proin sem leo, pulvinar Id gravida non,
pharetra at arcu. Morbi vitae mi ut massa tincidunt placerat. Quisque quis dui

sem, non venenatis nunc. Aenean in erat et arcu facilisis cursus! Nam lacinia
massa a tellus fringilla id euismod nisl tincidunt. Pellentesque habitant morbi

Menu ftem tristique senectus et netus et malesuada fames ac turpis egestas. Ut a turpis at

Figure 57 - Page Previewed in Browser

Converting Your Menus to Include Pages

If you wish to convert your vertical menu to a Design Time Include please follow the previous
instructions (see Converting Your Menus to Include Pages)

Navigation Resources

e Website Navigation - Website Navigation Structure
e Navigation Menu - Creating A Navigation Menu
e Website Navigation

Whatever your final choice of navigation is, it should be a consistent navigation scheme from
page to page throughout your site. This helps the website visitor learn your website navigation
system.

CSS Menu Resources

e CSS Library Horizontal CSS Menus

e CSS Library Vertical CSS Menus

e (CSS Play Menus

e CSS MenuMaker

e CSS Express Drop-Down Menus - by the folks at ProjectSeven. This is my absolute favorite for a
CSS dropdown menu.

You will also need to make sure that whichever menu system you use, that it renders in all
browsers.
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Validating Your Pages

Before you can save the page you have created as a Dynamic Web Template or DWT for short, you
should make sure that both your HTML code and your CSS code validates. To understand WHY it is
important to validate your code read Code Validation - Clean Code by Susan Emerson. Expression Web

has some tools within the program that will help you with validating your page.

Compatibility Checker on Status Bar

Much of this information will apply to Expression Web 3.0 as well as 4.0.

As you continue to build your site and work on your pages, you should get in the habit of validating the
page BEFORE you publish it. Expression Web has various tools to help you with this. Two very helpful
options that you should have already set are located under Tools > Page Editor Options > General tab.
They are:

1. Highlight Invalid HTML which will display invalid HTML in a specific color scheme (the default is
red text on a yellow background). If you choose to change the colors, you can specify this color
scheme in the Color Coding tab of the Page Editor Options dialog box.

2. Highlight Incompatible HTML which will display a wavy underline beneath code that isn't
compatible with HTML standards.

Status Bar

The Status Bar is located on the lower right hand corner of your workspace and displays among other
things information about the file you are editing, such as file size, HTML schema, and CSS schema.

B~ &~ XHTML10S 754KB -

Figure 58: Status Bar From L to R, the symbols: Incompatible HTML - Invalid HTML - HTML schema - File Size - Visual Aids
Mode - CSS schema - Current Page size

This article will discuss the first two, Incompatible HTML and Invalid HTML. The above example shows
there are compatibility errors detected and HTML errors detected.

Compatibility Checker for Incompatible HTML
You will need to work in Split View or the Compatibility errors will NOT show as errors.

If you click the first icon, Incompatible HTML, you can choose to do one of the following:

1. GoTo Error
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2. Run Compatibility Checker

3. Schema Options

Go To Error
Run Compatibility Checker...

schema Options...

Figure 59: Incompatible HTML > Go To Error

Selecting 'Go To Error' will take you to the error (pictured below). Hovering over the highlighted error
will give you some additional information on the problem.

fleb=ite." target=" blank" href="http://www.genea

- FEEEAL

- T ST CE =

| In XHTML 1.0 Strict the attribute_'target' is not permitted for the <a> fag,

Figure 60: Compatibility Error

In this case, | am told that with the XHTML 1.0 Strict doctype, "target" is not permitted for the <a> tag.
The target attribute is not allowed in strict doctypes which is what this site uses. If | delete it, the
compatibility error disappears. Work your way through each of the errors that are shown. You can use
the F9 key to go to the next error. Unsupported attributes, missing attributes, and improperly nested
tags are all highlighted inline by the compatibility checker.

You could also run 'Compatibility Reports' from the 'Tools' menu. You can choose to check one page,
several pages or the entire site.

Invalid HTML Code
If you click the second icon, Invalid HTML, you can choose to do one of the following:

1. GoTo Error

2. Run Compatibility Checker

Go To Error

Run Compatibility Checker...

'ﬂ, &8 XHTML10S5 104 KB

Figure 61: Invalid HTML > Go To Error
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Selecting 'Go To Error' will take you to the error (pictured below). Hovering over the highlighted error

will give you some additional information on the problem.

=

= 'r'l"':-
b1 Empty elements must have an end tag, or the start tag must end with />, L

Figure 62: Invalid HTML Error

In this case you need to add a space and the closing forward slash <br /> If you are using the default

XHTML doctype, then you need to remember XHTML elements must always be closed.
Examples:
This is not correct.

<p>A line of text.
<p>A line of text.

This is correct.

<p>A line of text</p>
<p>A line of text</p>

This is not correct

<hr>
<br>

This is correct:

<hr />
<br />

If you are using the XHTML doctype, you can correct many of this type error by right clicking in Code

View and selecting 'Apply XML formatting rules.'

Additional Resources on Validation:

e Validate HTML Code - HTML Code Validators
e Validate CSS Code - CSS Code Validators
e Validation Tools
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Creating Your Dynamic Web Template

Now that you have created your page, and you know that it validates you can save it as a Dynamic Web
Template or DWT for short. There is a FREE Ebook available on Dynamic Web Templates written and
made available by Tina Clarke. | encourage you to download and use Expression Web DWT EBook

What is a Dynamic Web Template?

A Dynamic Web Template - DWT - is an HTML/XHTML based master copy of a web page that you create

to contain formatting and page elements such as text, graphics, page layout, styles, and regions of a web
page that can be modified. You can attach a Dynamic Web Template to the pages that are part of a web

site, and that template defines the layout for those pages. A website can contain more than one DWT.

Why it’s a good idea to use a DWT?

One of the most important concepts of website design is to maintain a consistent look and feel for your
site. Using a DWT makes this possible. As a webmaster you should attempt to provide:

e Consistent navigation throughout your site

e Consistent look throughout the site

e Provide basic pages such as a Sitemap, Contact, About and Search pages. Your visitor should be
able to reach your home page from any page on the site.

e Provide copyright information and a disclaimer or terms of use page as well as a Privacy Policy.
These are quite often found in the footer of a page.

Creating a Dynamic Web Template - DWT

Step 1: Before you can create a Dynamic Web Template you have to have a page to work with. Create
your template as a HTML or XHTML document with all of the elements of the page that will be part of
every page on your site - masthead, site navigation, footer. Make sure it also includes any meta tags
you want to use. Save the template and make sure it validates BEFORE you create your DWT. If you
followed all of the previous steps, you will have created your basic template.

Step 2: With your page open in EW > File > Save As > Save as type - dropdown button > Select Dynamic
Web Template from the dropdown > Give the file a name site.dwt > Click Save
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= Hide Folders

Tools -

Save |

Cancel

Figure 63: Save As Dynamic Web Template

Step 3: The DWT won't do you much good without editable regions - regions that can be changed on the
pages the DWT is attached to. Once you save the page as a DWT, one editable region is created for the
doctitle. You will need to create additional editable regions, for the content area, your keywords and

description meta tags.

<!-— #BeginEditable

<!—— #EndEditable -

"doctit

<title>Sample Site</title>

—

le"™ ——>

Figure 64: Editable Region for <doctitle>

NOTE: The editable region name must be all one word and in lower case. You can call it anything you
want, however relating it to the placement on the page helps keep the various regions straight.

Step 4: To create an editable region for your keyword and description meta tags, Copy and Paste the <!--
#BeginEditable "doctitle" --> just before your description meta tag. Copy and Paste the <!-- #EndEditable
--> tag right after the keywords meta tag. Double click the 2nd occurrence of the doctitle tag and change

it to headsection.

<!-— #BeginEditable "doctitle™ -—->
<title>Sample Site</title>

<!-— #EndEditable —->

<l-- #BeginEditable "headsection" -->
<meta name="keywords" content=" " />
<meta name="description" content=" " />
<!-— #EndEditable —->

Figure 65: Editable region for headsection
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| also add an editable region for any scripting tags that might be a part of some of my pages.
<!-- #BeginEditable "scripting" -->

<I-- Scripting area here -->

<!-- #EndEditable -->

Step 5: Select all the text in the main text area of your DWT page > Right click with your mouse > Select
manage editable regions from the drop down > In the region name box type maincontent > Click the
add button > maincontent is added to your editable regions > Click the close button.

Region name:

maincontent

Other regions on this page:

Mame
doctitle

headsection

m
[=]
m
(%]
[=]
x)

. 4

Figure 66: maincontent editable region

NOTE: In Code View, make sure the editable region is INSIDE your <div id="main-content"> or you will
wipe out the div tag when you attach the DWT to your content pages.

<div id="main-content">
<!-— ¥BeginEditable "maincontent" -->
<hl>Your Heading Tag would go here.</hl>
<p>Content goes here</p>

<!-— ¥EndEditable —->

Figure 67: Code View - maincontent editable region

You can now see that the text on your DWT page is surrounded by a yellow border and titled
maincontent

NOTE: Expression Web 4.0 has a bug that causes the yellow/orange outline to NOT APPEAR around the
editable region. You can still edit that region but you will not see the outline surrounding the area. THIS
BUG HAS BEEN FIXED IN THE FREE VERSION OF EXPRESSION WEB 4.
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Figure 68: Design View maincontent editable region

Step 6: If your navigation is going to change from section to section, you will need to create an editable

region for that area too. Once finished, save your page.

Step 7: Now that you have created your DWT, you need to check and make sure it works correctly. Click
on the new page icon > A new blank page is created for you > Click on Format from the top menu bar >

Select Dynamic Web Template > attach dynamic web template.

Fglmatiloals Table Site Data View

A4 New Style.

55 Styles 3
S5 Properties.

Tzg Properties...

Font...

Paragraph...

il 4 =

Bullets and Mumbering...
Borders and Shading...

Position...
Behayiors...
£3 Layers..
Dynamic Web Template » Attach Dynamic Web Template...
Master Page » Detach from Dynamic Web Template

Frames 3 Open Attached Dynamic Web Template
i Background..
(@ Page Transition...

Update Selected Page
Update All Pages
Remove Formatting ~ Ctrl+Shift+Z &  Update Attached Pages

& Properties... Alt+Enter | 33 Manage Editable Regions...

Figure 69: Attach Dynamic Web Template

Click on site.dwt from the file list, and then click OK. Expression Web will tell you that 1 file has been
updated. Expression Web has attached the DWT to your blank page. If everything looks OK, your DWT is

ready to use.
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What Is Search Engine Optimization - SEO?

Search engine optimization (SEQ) is the process of improving the volume or quality of traffic to a web
site or a web page (such as a blog) from search engines via "natural" or un-paid ("organic" or
"algorithmic") search results as opposed to other forms of search engine marketing (SEM) which may
deal with paid inclusion. The theory is that the earlier (or higher) a site appears in the search results list,
the more visitors it will receive from the search engine. SEO may target different kinds of search,
including image search, local search, video search and industry-specific vertical search engines. This
gives a web site web presence. ~ from Wikipedia ~

Search Engine Optimization (SEO) refers to a collection of techniques to improve your site's ranking in
search engines, be it Google, Yahoo, or any of the others.

One of the new features of Expression Web 4.0 includes Search Engine Optimization tools. The SEO
Checker feature of Expression Web helps you understand and apply search engine ranking best practices
to obtain the highest possible search engine ranking.

The SEO Checker analyzes specific areas of your site and specific elements in the individual pages of
your site. Using the following guidelines can help improve the search-engine ranking of your site.

IMPORTANT: Before you attempt to use the SEQ Checker and SEQ Report, | encourage you to learn at

least the basics of Search Engine Optimization by following some of the basic tips listed in the article
below.

How Does Search Engine Optimization (SEO) Work?

A user goes online and types keywords into the search engine of his choice - Google, Yahoo, or Bing.
The user may be looking for information such as how to design a web page or a product like a new
wireless router. The search engine then returns a list of pages, with each ranked according to its
relevance to the user's search query. Search engines use a web crawler or spider to discover and index
pages. An important task for you, the web developer is to make sure that search engine crawlers can
find and index information on your page so that a search query will guide users to that page.

Pages that have been optimized for search engines follow coding practices that provide relevant
information to search engines quickly. Read How Search Engines Read Web Pages

As you work with each page, you need to do YOUR research as to what keywords users search for. Some
tools you can use for your research include:

e Good Keywords
e FREE keyword suggestion tool

Basic Search Engine Optimization Techniques
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There are some basic SEO best techniques you can follow that will help with your search engine
optimization. They include BUT are not limited to:

Page Titles

Create unique and accurate page titles that are relevant to the content of that particular page. They
should be short and descriptive using about 60 to 65 characters. Remember, that not everyone will
enter your site through your "front door." Some may choose a "back door" or the "kitchen door." Treat
each and every page as an entry point to your site with unique content and a unique page title.

The page title goes between the <title></title> tags within the head section of your page. The page title
tells BOTH the users and the search engines what the page is about.

Page titles can be added from within Expression Web by right clicking on the page and selecting 'Page
Properties' > 'General' tab and typing the "Title" in the appropriate box.

Example: <title>Search Engine Optimization - SEO - Search Engine Optimization Techniques</title>

Meta Tag for description

A page's description meta tag gives Google and other search engines a summary of what the page is
about. The description meta tag goes within the head section of your page and should be limited to 150
to 200 characters.

<meta name="description" content="Brief description of your site goes here." />

Description meta tags are important because Google and the other search engines might use them as
the description that appears under a page's title and above a page's URL in a search result.

Good practices for the description meta tag include"
Accurately summarize the page's content.

Use unique descriptions for each page.

Use the exact title of your page within the description meta.

Page descriptions can be added from within Expression Web by right clicking on the page and selecting
'Page Properties' > 'General' tab and typing the "Page Description" in the appropriate box. View
Screenshot

Meta Tag for keywords
As of September 2009, Google no longer uses the keyword meta tag in ranking web search results and

support for its use has dwindled as it was easily abused. If you choose to use the keyword meta tag, it is
placed in the head section of your page and would look like this.

<meta name="keywords" content="keyword, keyword,keyword" />
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The keywords you use should appear on your pages and separated by commas. This tag should NOT be
used to stuff with keywords and limited to approximately 150 characters.

Page keywords can be added from within Expression Web by right clicking on the page and selecting
'Page Properties' > 'General' tab and typing the "Keywords" in the appropriate box.

File Names

The file names you choose for your pages (and images for that matter) should reflect the content of the
page and the keywords for that particular page. The file name should be short using two or three of your
keywords and be unique for each page of your site.

You should never use spaces in your files name and hyphens are preferred over underscores. Do not use
overly long file names for either your pages or your images.

If you use spaces in your file names, they will show as my%20file.html. Instead use my-file-name.html.

Heading Tags

Use heading tags appropriately to give structure to your page NOT to style the presentation. There are
six sizes of heading tags, beginning with <h1>, the most important, and ending with <h6>, the least
important. Itis NOT likely you will use all six heading tags on a page. You can read more about heading
tags in this article by James Huggins.

Good practices for heading tags include:
Imagine you're writing an outline.

Use headings sparingly across the page.

Use css to style the look of your heading tags.

Alt Attribute

The "alt" attribute allows you to specify alternative text for the image if it cannot be displayed for some
reason. For those folks who are using alternative technologies, such as a screen reader, the contents of
the alt attribute provide information about the picture. The "alt" attribute is REQUIRED in order for
your page to validate. The alt text should give a brief but accurate description of the image using your
keywords if it makes sense.

It is also good practice to store your images in their own directory rather than have them spread out
throughout your site.

Alt tags can easily be added in Expression Web by right clicking on an image, selecting 'Picture
Properties' and on the 'General' tab under 'Accessibility’ typing 'Alternate Text' in the appropriate box.

Example: <img alt="Screenshot Page Editor Options General tab." height="225"
src="images/ew4-peo-general-tab_small.jpg" width="200" />
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Title Attribute

Unlike the TITLE element, which provides information about an entire document and may only appear
once, the title attribute may annotate any number of elements. The title attribute specifies extra
information about an element and is most often shown as a tooltip text when the mouse moves over
the element.

To add the title attribute to hyperlinks in Expression Web, highlight the text you wish to use, and right
click or hold down the Ctrl key + K and select hyperlink. In the dialog box, either browse to the file you
want to link to OR type the url of the page in the Address: field. Click the 'Screen Tip' button and type

the text you wish to use.

IMPORTANT: There is a bug in Expression Web 4.0 that causes the hyperlink dialog box to lose focus if
you are working in Design View. Once you click OK from the Screen Tip text box, EW will bring up the last
open window you were working with. You will need to return to the EW editing window to continue.
This does not happen if you are working in code view and simply type the title attribute with the text
you wish to include.

Example: <a title="Screenshot: Setting up Expression Web Page Editor Options > General
tab." href="images/ew4-peo-general-tab.jpg">

Content

While all of the tips listed in the previous section will help with Search Engine Optimization, the content
of your site is the meat of the site. According to Google, you should "create a useful, information-rich
site, and write pages that clearly and accurately describe your content. Think about the words users
would type to find your pages, and make sure that your site actually includes those words within it."

You might find these articles helpful:

e Website Content
e Developing Quality Content
e Content SEO - Does Content Play a Role in SEO?

In order to be found by the search engines, your content must be readable by them. If your pages are
full of flash movies, images and such with very little content, there will not be much there for the spiders
to index when they visit your site. So take your time, do your keyword research and develop your
content around those well researched keywords.

Remember, that your visitor can enter through any door of your site not just your "front door" or Home
Page. Spend as much time developing the content for those other doorways as your front door.

Summary
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Now that you know a little more about some of the basics you need to do to optimize your site for the
search engines, you can use the newest tools available in Expression Web 4 SEQ Checker and SEO

Reports.

To learn more about Search Engine Optimization, make use of the resources listed below.
SEO Resources

e Google's Search Engine Optimization Starter Guide

e Search Engine Optimization (SEQ) from Google
e FREE SEO Techniques Training Class
e SEO Technigues - SEO Optimization Technigues EBook

e Yahoo! Search Content Quality Guidelines
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Using the Expression Web SEO Checker and
Report

IMPORTANT: Before you attempt to use the SEO Checker and SEO Report, | encourage you to learn at
least the basics of Search Engine Optimization. You will also have more manageable results if you select

the pages you want to run the report on combined with the filters OR simply run the checker on the
page you are working on.

Search Engine Optimization (SEO) refers to a collection of techniques to improve your site's ranking in
search engines such as Google or Yahoo or any of the others. One of the newest features in Microsoft
Expression Web 4 is the SEO Checker which analyzes your site against the best practices for getting the
highest possible search-engine rankings for your site.

What does the SEO Checker do?

The Expression Web SEO Checker will analyze your site using techniques similar to what a search engine
would use. It then provides helpful information so that you can optimize the pages of your site for
maximum search engine ranking. The detailed report generated will look something like the graphic

shown below.

Search Engine Optimization

L8 Problem Summary ~ Help Topic ~ Page - Line ~ Issue Type b
7 |#| The <meta name="description"> tag should contain 150 or fewer ... WEB1023 xmins-validation-error.html (... 12 Error
. |2 The <img> or <area> tag does not have an 'alt’ attribute with text. ~ WEB1009 xmins-validation-error.html (... 39 Warning
b |2] The <a> tag text is too general to provide search benefit. WEB1058 xmins-validation-error.html (... 71 Error
&8 @ The <a> tag text is too general to provide search benefit. EB1058 xmins-validation-error.html (... 72 Error
_"" The <a> tag text is too general to provide search benefit. WEB1058 xmins-validation-error.html (... 73 Error
:‘__ The <a> tag text is too general to provide search 1, 25 tag contains the text 'Site Map', wehich prﬁ.v.id.e.s no search benefit. Consider ch_anging the link text to |
|2 The <a> tag text is too general to provide search provide meaningful, descriptive link text.
|#] The <a> tag text is too general to provide search benefit. WEB1058 xmins-validation-error.html (... 80 Error
|2] The <a> tag text is too general to provide search benefit. WEB1058 xmins-validation-error.html (... 250 Error
|2] The <img> or <area> tag does not have an 'alt’ attribute with text. ~ WEB1009 working-with-css.html (Work... 38 Warning
|2] The <a> tag text is too general to provide search benefit. WEB1058 working-with-css.html (Work... 71 Error
1@ The <a> tan tevt is ton neneral to nrovide searrh henefit AWERTNSA Jwnrkina-with-res html Adinrk 72 _Error

Found 2790 searchability problem(s) in 239 page(s).

Figure 70 - SEO Report.

Hovering your mouse over the 'Problem Summary' listing will give you more details on the problem
listing as you can see by the enlarged thumbnail.

The SEO Checker report lists the following classes of SEO messages:

NOTE: Clicking on the links below will take you to the online help for Expression Web 4 with many more
details on each of the items listed. The same information is available from the 'Help' menu > 'User
Guide' or clicking F1.
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Content is not where search engines expect to find it. These rules identify content or markup that is not

located where search engines are likely to look for it.

The <title> tag is missing

The <img> or <area> tag does not have an 'alt' attribute with text

The <noscript> tag is missing

The <title> tag contains placeholder content that provides no search benefit
This page contains no <h1> tag

Content or markup follows patterns that may be associated with deceptive practices. These rules

identify content or markup that search engines may perceive as using practices designed to artificially
inflate the search rankings of a page or a site.

The contents of the <meta name="description"> tag are too long

The <meta name="keywords"> tag contains multiple instances of a single term
The <meta http-equiv="refresh"> element is being used for redirection

The title and description for the page are identical

Content or markup interferes with the ability of search engines to analyze a page. These rules identify

content or markup that prevents search engines from accurately analyzing your site.

The <body> tag is missing

The <title> tag is not defined in the <head> tag section
The page is not well-formed The <html> tag is missing
The <h1> is not inside the <body> tag section

Content or markup reduces the appeal of a page in search-engine results. These rules identify content or

markup that search engines can analyze only partially.
The <title> tag contents are too long.

The description for the page is missing.
The <meta name="description"> tag contents are too short
The <meta name="description"> tag should be declared only once in a page

Content causes search engines to consider two or more pages to be relevant to the same search term.

These rules identify content or markup that may cause search engines to report that more than one
page is relevant to a search term.

A URL that points to a directory should end with a slash mark (/)
The hyperlink ends in an ampersand

The title is not unique

The anchor is not formatted consistently

The hyperlink contains a session ID
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Content or markup blocks search engines from analyzing your site. Blocked-content rules identify

content or markup that blocks search engines from analyzing your site.

The hyperlink contains an invalid character.
The hyperlink contains a nofollow attribute value
The hyperlink contains too many query string parameters

What the SEO Checker Does Not Do.

While the SEO Checker can make you aware of problems and help you correct problems with
the markup and content of your site, there are other things you will need to do to optimize
your site for the search engines. Ask yourself these questions:

e Do the search engines see your site as two separate sites www.my-domain.com or my-
domain.com?

If you type site:my-site.com/ into the search box, do you get the same number of results if you
type site:www.my-site.com/ into the search box? If not see Google Canonical problems - www
Versus non.www.

e Have you taken care of building incoming links to your site from other sites? You should be
linking to pages within your site as well as having external sites link to your pages.

e Have you done the keyword research for your content? Don't guess, use some of the online
tools to research what terms people use in searching for your content and use those keywords
in developing your content.

e Have you used descriptive file names to name your pages as well as your images? Remember
NOT to use spaces but hyphens in naming your files.

e And last but not least, have you developed unique and original content for your pages.

To generate an SEO report

Step 1: Do one of the following:
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¢  With your site open, click 'Tools ' on the menu, then select 'SEO Reports.' The 'SEO Checker'
dialog box is displayed.

| SEO Checker l= |2

Check ‘

Check options

Check where: Shaow:
(@) All pages [#]Errors
(") Open page(s) [#]warnings
() Selected pages Learn more about SEQ

{ :,-Current page

Check ] l Close

. 4

Figure 71 - SEO Checker dialog box

e Click 'Check’ to start generating the SEO report.
e  With your site open, on the 'Panels' menu, click 'SEQ.' The SEO panel is displayed.

Click ®#¥+to0 open the SEO Checker dialog box.
Step 2: In the SEO Checker dialog box, specify the pages that you want to analyze.

e To specify all pages in a site, under 'Check where', click 'All pages.' NOTE: If you have a large
site, this can give you an overwhelming report.

e To specify only the pages you have open, under 'Check where', click 'Open pages.'

e To specify pages from the 'Folder List,' select the pages that you want to check, and then, under
'Check where', click 'Selected pages.' If you do not have the Folder List showing, click the
'Panels' menu, and select Folder List.

e To specify the active page, under 'Check where', click 'Current page.'

Step 3: Specify the types of items that you want to show in the SEO report.

e Toinclude items that are considered errors, select the 'Errors' check box.
e Toinclude items that you may not have to adjust, select the 'Warnings' check box.

Step 4: Click 'Check.' The check may take some time to complete, depending on the options that you
selected and the size of the site. The results are displayed in the SEO panel (shown below) when the
check is completed.
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Found 2790 searchability problem(s) in 239 page(s).

Figure 72 - SEO Report.

The results may be sorted by clicking on any column label.

To apply a filter to an SEO report

In the SEO report, on the column label, click "wand select the filter condition that you want to apply to
the list. The filter settings are saved when you close the site. If you can't find files in a new report, you
may have filters applied from a previous session. You can create custom filters for your SEO report. For
more information, see Customizing filters.

Example: If you have a folder named _includes and one named gallery and you want to exclude the
contents of those folders from the results, click on the page label drop down and select "custom.'

Apply Custom Filter l g iﬁ-]
Show rows where:
Fage
’does not contain - ] _includes -
And @ Or
Idoes not contain - ] gallery| -
[ oK l | Cancel

Under 'Show rows where': Page; select does not contain and type in _includes. Tick the Or does not
contain. Type in gallery. Click OK.

Your list now shows none of the files within the _include folder or the gallery folder. Each of the labels
will allow you to apply two filters.
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To remove a filter from an SEO report
Right-click anywhere in the report and then click 'Clear Filters.'

Understanding the SEO Report
When you generate a report, the SEO panel contains the following columns:

e Page - Lists the page that contains an issue and the location of that page.

e Line - Lists the number of the line in Code view that contains the issue.

e Issue Type - Lists the type of issue, either Error or Warning.

e Problem Summary - Describes the code error or the reason the code is incompatible with the
schema. The content of this column also appears in a ScreenTip when you point at a row in the
panel or when you point at the source of the problem in Code view.

To sort the list of results, on the Search Engine Optimization tab, click the name of a column. To reverse
a sorted list, click the name of the column again. You can also rearrange columns by dragging them.

SEO panel buttons

Run SEO Checker

< Previous Result
44— Next Result
8 4—— Refresh Changed Results

Figure 73 - SEO panel buttons

e To open the SEO Checker dialog box, click Run SEO Checker.

e To open the web page that contains the next or previous result in the list, and to highlight the
issue, click Next Result or Previous Result. To go to the next issue on an open page, press F9.

e To recheck pages that were checked and have changed, click Refresh Changed Results.

e To sort the list of results, click the name of the column that you want to sort by. To reverse a
sorted list, click the name of the column again. To restrict the results to those that fit the criteria
you select, click the down arrow that appears in the heading of a column and select a criterion
by which to filter the results.
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e When you right-click a row, a shortcut menu provides the following additional options:

2 (o to Page I}
4A. Problem Details

A
™

Learn More

Select Resulting Files in Folder List

'R

Clear Results

Refresh Changed Results

Copy Selected Results
& Clear Filters

Figure 74 - SEO shortcut menu

0 Goto Page - Opens the web page that contains the result and highlights the issue.

0 Problem Details - Opens the Problem Details dialog box, which contains more
information about the selected issue.

0 Learn More - Opens the help topic for this issue type, which contains more details and

suggestions about how to correct the issue.

Select Resulting Files in Folder List - Locates the selected pages in the Folder List panel.

Clear Results - Clears the results list.

Refresh Changed Results - Rechecks the specified pages that have changed.

Copy Selected Results - Copies the selected results of the report as a table.

Clear Filters - Clears all filter criteria and sets the Filter menu of every column to All.

O O O O O

Problems Details and Fixes SEO Reports

While the SEO Reports can be a tool for correcting problems with your site, it is just that, a tool. If | use
this site an example and run the SEO Reports with the errors setting ticked and All Pages ticked, | get
2,650 searchable problems in 235 pages. Overwhelming to say the least!

The problems listed below are just some of those you might encounter while running the SEO Checker
on your site.

The anchor text contains values that provide no search benefit
Problem Summary message reads: "The <a> tag text is too general to provide search benefit."

If I hover over one of the listings OR right click and select 'Problem Details', | get "The <a> tag contains
the text '"Home', which provides no search benefit. Consider changing the link text to provide
meaningful, descriptive link text."

Clicking on 'Help Topic', gives me the following explanation:
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The <a> tag appears to contain generic text, such as "link" or "click here." If a hyperlink points to content
that is relevant to the site, the search ranking of the site may be reduced unless the anchor text
accurately describes the target of the hyperlink. Search engines use the contents of <a> tags to provide
details about the page to which the <a> tag links.

Many Problem Summary messages of this type relate to my menu which has to be short to fit in the
allotted space. What can | do to help the search engines? | add a title attribute to the hyperlink. While
this will not change the SEO Report problem summary listing, it will help the search engines understand
what the text link points too.

The description for the page is missing.
Problem Summary message reads: "The description is missing."

If I click on the 'Help Topic', | get the following explanation:

Because search engines typically display the content of the <meta name="description"> tag in search
results, each page should have a single, unique description that accurately describes the contents of the

page.

Since the Page label column indicates the problem is with one of my included menus, it is not one | need
to be concerned about. However, you should make sure that all your pages that should have a page

description do.

Hyperlinks that point to a directory should end in a slash (/)
Problem Summary message reads: "Hyperlinks that point to a directory should end in a slash (/)"

The Problem Details explain that most pages in a site contain at least one hyperlink to a URL that points
to a directory (such as www.expression-web-tutorials.com/ew4/). If several hyperlinks in which the URL
target is the same directory are formatted differently, they may be treated as separate links. What is
delivered to the browser is the default page for that directory i.e. index.html or default.html

The <meta name="keywords"> tag contents are too short

Problem Summary message reads: file-name.html, line #: The contents of the <meta
name="keywords"> tag are too short. If the contents of the <meta name="keywords"> tag are too short,
search engines may not consider them to be relevant. Consider lengthening the contents of the <meta
name="keywords"> tag.

Support for the keyword meta tag has dwindled and Google no longer uses this tag in ranking web

search results. If you choose to use it, limit it to 150 characters including spaces, and include only those
words you use in your content.

The <title> tag contents are not unique within the site
Search engines use the contents of the <title> tag both to provide some of the details about the site
contents and to provide specific details about the contents of a page. Each page should have a single,
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unique title contained inside a <title> tag inside the <head> tag section of the page. It should be no
longer than 65 characters.

The <img> or <area> tag does not have an 'alt' attribute with text

The alt attribute is meant to be used as an alternative text if the image is not available and is required in
order for your page to validate. The alt attribute text is also used by audio readers for the visually
impaired. However, if you are using spacer graphics or decorative images they should contain an empty
alt attribute.

The alt text should give a brief but accurate description of the image using your keywords if it makes
sense.

The <noscript> tag is missing

Every page that contains a <script> tag should have a corresponding <noscript> tag. Search engines will
not index the contents of a <script> tag. If code inside a <script> tag generates search-relevant page
content, that content may not be analyzed by search engines at all.

The <noscript> tag is used to provide an alternate content for users that have disabled scripts in their
browser or have a browser that doesn’t support client-side scripting.

As an example, the footer of this site uses a script to generate the copyright information so that it
updates automatically. The <noscript> tag provides the same information in text format. Or simply use
<noscript>Your browser does not support JavaScript!</noscript>

This page contains no <h1> tag

In semantic web design, headings provide important organizational and summary information. Each
page should have a single <h1> tag that summarizes the contents of the page. If the page contains a
significant amount of text, it should be organized with <h2> through <h6> subheadings that summarize
and categorize the text that they precede. Search engines rely on correctly used headings to determine
the organization and contents of a site.

Any page that does not have an <h1> tag is going to generate this error including any include pages. Use
the filters to filter out these pages.

Your <h1> heading tag should match your title tag <title> tag and there should be only ONE <h1> tag on
your page.

Summary

The SEO Checker is just a tool for you to use in evaluating whether you have followed good Search
Engine Optimization practices in building your pages. It can be a little over zealous in giving you a listing

of the problems so you will need to filter the results in the report.
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Do some research and learn what are the best practices to follow in designing your pages. Soon it will
become second nature to make sure such things as page titles, descriptions, semantic markup, and
keyword use are part of your web development strategy.

Don't try and fix everything that needs fixing on your site at one time. You will become overwhelmed.
Take one page at a time and fix the problems with that page. Go on to the next one.

Additional SEO Resources

e Google's Search Engine Optimization Starter Guide

e Search Engine Optimization (SEQ)

e Yahoo! Search Content Quality Guidelines

e How to Improve the Position of Your Website in Yahoo! Search Results
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Working with Images in Expression Web

Before you insert a graphic image into any newly created page, first save the page and give it a name -

File > Save or Ctrl + S. While this is NOT required, some users have had problems with paths not

resolving correctly when the page has been saved and named for the first time after images were added.
Therefore it is considered good practice to save the page before inserting images, hyperlinks, and style

sheets.

This tutorial also assumes your images are already located in your website folder. If they are not, you

will either need to import them into the web, or save them as part of the web.

Importing Your Images

e  With your site open in Expression Web, on the File menu > Import > File or Folder
e Inthe ‘Import’ dialog box click Add File or Add Folder >

e Inthe ‘Add File to Import List’ that pops up, browse to the folder where the files are located

e Hold down the ctrl key and click all files you want to import > Click OK

Import

File

C:\Users\Patricia\Documentsh...
C:\Users\Patricia\Documents)...
C:\Users\Patricia\Documents)...
C:\Users\Patricia\Documents),...

URL
snowflakes?.png
snowflakes.png
reset.css
leaf-twirl.png

| 2 [
Add File...
| Add Folger...|

Add Folder...

viod

Remave

I

Figure 75 - Import Files dialog box

Once you click OK, you will see all of the files you selected for import now listed as part of your new

web.

NOTE: If you store your images in an image folder, you can drag the images you have just imported into

that folder.
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Inserting Images into a Web Page

There is a new feature in Expression Web 4.0 SP2 called 'Thumbnail Previews' which is located at the
top of the Folder List. It gives information on the currently selected image, such as: a small thumbnail,
dimensions of image and file size. You can click <img> to copy an img tag to the clipboard which can
then be pasted into code view and will look like this:

<img src="2nd-edition-cover.jpg" width="329" height="452" alt="" />

If you click CSS, you can copy the css properties to the clipboard, which can then be pasted into your
style sheet and using the same image as above would look like:

background-image: url("2nd-edition-cover.jpg"); width: 329px; height: 452px;

Folder List

2nd-edition-cover.jpg
H 33.4 KB, 329 x 452 px

= n images
e M boed7bge
-] n extra
e edvion-covrapg
Eg 404.gif
B 404-red.tic
ty-options.jpg
ty-properties.png

owser.jpg
M add-font-family.jpg
dd-font-family_small1.jpg

a
add-images.jpg

adjust-hyperlinks.png

Ainet-hunarlinlo-tn nnn

Figure 76 - Thumbnail Preview

To insert an image into your web page, place your cursor on the page where you want the image to
appear and do one of the following:

e From the Insert menu > Picture > From File > Select the image > Click Insert
e Drag the picture from the Folder List panel or Site View into the Design view of your page.

The Accessibility Properties dialog box allows you to insert ALT text and a Long Description if needed.

e Alternate text makes your image accessible to screen readers. It also is visible in some browsers
when the graphic is downloading, when it can't be found, or when a site visitor moves the
pointer over it.

e See, When to Provide Long Descriptions for more information on this accessibility feature.
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Accessibility Properties |‘Q—SE|

Alternate text: Screenshot Accessibility Properites dialogue box.

Long description:

[¥] show this prompt when inserting images oK ] [ Cancel ]

Figure 77 - Accessibility Properties Dialog Box
Check in code view and you should see something like this -

<p><img alt="Screenshot of Accessibility Properties Dialog Box." src="images/accessibility-properties.png"
width="408" height="127" /></p>

If the image you are inserting is NOT already located within your website folder, when you save the
page, the embedded files dialog box pops up. Click Change Folder and select the folder where you want
your images stored. Click OK > OK and the images will be stored in the correct folder and now be a part
of your website.

Save Embedded Files (2 el
Embedded files to save: Picture preview:
Name Folder Action

¢ | red-holly.png images/ Save

Select the folder where
you want the images saved

)
~N0

I Rename ] I Change Folder... ] [ Set Action... ] IPictureFiIeType...]

[ o ][ corcel |

Figure 78 -- Save Embedded Files dialog box.

About the Picture Properties Dialog Box

The Picture Properties dialog box gives you access to the most commonly-used picture attributes. Right
clicking or double clicking the image will bring up the Picture Properties box.

The following are the options available from the Picture Properties dialog box in Expression Web. There
are two tabs - General (Figure 80 - Picture Properties General Tab) and Appearance (Figure 81 - Picture
Properties Appearance Tab).
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Picture Properties Iil_g_hj

General fappearance

§

images/save-embedded-files.png] Browse... ] [ Edit...
Picture File Type...

Accessibility

fernate Text: | Screenshot Save Embedded Files.

Long Description: Browse...

] Location: Browse...

Target Frame: Parameters...

0K ] [ Cancel

Figure 79 - Picture Properties General Tab

General Tab

PICTURE: folder/file name of graphic image

ACCESSIBILITY:

Alternate Text: Type the text you want to be displayed for pictures when the graphic is downloading,
when it can't be found, or when a site visitor moves the pointer over it. This text will also be used by a
screen reader if your viewer is using one. Creating Effective Alternative (alt) Text

Long Description: There are times a few words may not be enough to describe your image. Charts and
graphs are examples. Click Browse to select a file that contains a longer description of the picture.
LONGDESC Attribute

HYPERLINK:
Location: If you want to link your image to a web page or larger image, you insert the hyperlink here.
You may also use Insert > Hyperlink

Target Frame: If the current page is a frames page, this option indicates which frame the link should be
displayed in OR you can choose to have the image or page open in a new window.
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Picture Properties |@—§:§|

Appearance I

Wrapping style

IEI O O

Mone Left Right

Layout —)

Alignment: Default E‘ Horizontal margin: |0

Ll LANE] L3

Border thickness: = Vertical margin: 0
L Specify size Width: 517 |= Height: 351 [=
(@) in pixels @) in pixels
(7 in percent () in percent
Keep aspect ratio

oK l [ Cancel

L8 4

Figure 80 - Picture Properties Appearance Tab

Appearance Tab

WRAPPING STYLE: Specify how the picture floats in the page. Your choices are None, Left, or Right.
(Rather than use this option, you should create a style for floating your images and apply the style.)

LAYOUT:
Alignment: Specify how you want the picture to be aligned on the page. lllustrating Image Alignment

Border Thickness: Set the border thickness in pixels for the picture. Better yet, add the border to your
image using a graphic editor.

Horizontal margin: Set the left and right margin width in pixels. (This should be specified in your style
sheet.)

Vertical margin: Set the top and bottom margin width in pixels. (This should be specified in your style
sheet.)

SIZE: Expression Web automatically sets width and height properties for the image based on the actual
dimensions of the picture. Rather than resize your image by changing these dimensions, resize the
image using your graphic editor.

EXAMPLE: If | had indicated that | wanted my image left-aligned, with a 1px border, and a 4px horizontal
and vertical margin, Expression Web would have created the following style:

.styled {
float: left;
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border-style: solid;
border-width: 1px;
margin: 4px;

}
and my html code would look like this

<p><img alt="Screenshot of Picture Properties Dialog Box." src="images/picture-properties-appearance.jpg"
width="442" height="391" class="stylel" /></p>

| would then rename the style to .imglft and reuse it anytime | wanted.
NOTE:

e If you are going to change the dimensions of an image, it is best to do so using an image editor
NOT by changing the dimensions in your HTML code. WHY? Because the browser still has to
download the full size image before displaying it.

e If you are going to add a border to your image, it is also best done in an image editor.

Using Auto thumbnail

You can use Microsoft Expression Web to quickly create a smaller thumbnail-sized version of a picture to
use on your webpage which is then automatically linked to a larger image. It is preferable to optimize
your images and create your thumbnails within a graphics program but you can use this in a pinch.

Check doctype declaration
Make sure that you are using a complete doctype declaration on your page.
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Set the Default Properties for thumbnails
1. Tools > Page Editor Options > Auto Thumbnail Tab

)

Page Editor Options — @g
Autharing I Picture I Code Snippets | Ruler and Grid I InteliSense I Font Families
General | AutoThumbniail | Default Fonts | Code Formatting I Cs5 | Color Coding

ry

Pixels: 200 =

Height
Shortest side
Longest side

[ Beveled edge

[ OK ] [ Cancel

h

Figure 81 - Page Editor Options AutoThumbnail tab

2. Inthe Set box, choose your option then type a value in pixels. | use 200px.

3. | do NOT select a border thickness as | specify in my external sheet no border around body
images so | do not have the ugly blue border around hyperlinked images.
body img { border: Opx; text-decoration: none;}

4. lalsodo NOT choose to have a beveled edge as that is a rather out of date look.

Create a thumbnail picture

1. Insert the full size image into your page Insert > Picture > From File OR you can drag and drop
the image. NOTE: Make sure you save your page before you start inserting the images or the
path to your images may not be correct.

In the Accessibility Properties dialog box, insert an alternate description for the image.

Accessibility Praperties ’ k2 |’ |

Alternate text:  |picture of Barnett and Lonie Jones and children.

Long description: ) Browse.., |

[¥] show this prompt when inserting images ok ] | Cancel |

L8 4

Figure 82 - Accessibility Properties.
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N

Right click the image > Show Pictures Toolbar

]
3. On the Pictures toolbar > click the Auto Thumbnail button. (2nd icon from the left) OR
right click the image and choose Auto Thumbnail.

4. To save the thumbnail picture File > Save

5. Inthe Save Embedded Files dialog box, set the options you want and then click OK.
NOTE: | keep all of my images in a folder called images so | browse to that folder to save the
thumbnail image.
The following lines of code are added to your html code:

<a href="images/barnett-loni-jones-kids.jpg"><img alt="Picture of Barnett and Lonie Jones and children."
src="images/barnett-loni-jones-kids_small.jpg" width="200" height="276" /><!--
MSComment="autothumbnail" xthumbnail-orig-image="file:///C:/Users/Patricia Geary/Documents/My
Web Sites/test-auto-thumbnail/images/barnett-loni-jones-kids.jpg" --></a>

NOTE: file names for images should NOT contain spaces or special characters.
If you have a lot of pictures this could add a considerable amount of unnecessary code to your
page.

<td><a href="images/barnett-loni-jones-kids.jpg"><img &
mages,/barnett-loni-jones-kids_small.jpg"™ width="200" height

="Picture of Barnett and Lonie Jones and children.™
6" Jycl——

ges;’barne}:t—nel
dth="200" heigh

images/brow-earl-charley-dee.jpg"><img alt="" src="images/brow-earl-charley-dee_small.jpg"

a2il-orig-imamge="fils" : /aers/Patricia Gearv/Documents

Figure 83 - Code for 3 images BEFORE optimization.

6. The code created using the Auto Thumbnail feature will validate BUT you can clean up that code
considerably and do no harm to the images or your display.
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With your page open in Code View > Right Click > Optimize HTML
[ Optimize HTML | Y ]

Remove Comments
M All HTML comments
Dynamic Web Template comments
Script comments
o | All ather HTML comments
Remove Whitespace
HTML leading whitespace
HTML all whitespace
Remove Unused Content
| Merge adjacent tags
Emipty tags
Unused styles
Remove Ganerated HTML
Tracing Image and Interactive Button attributes
Generator and ProglD kags
| Ward HTML

| Restore Defaults | | ok Cancel

Figure 84 - Optimize HTML

<td><a href="images/barnett-loni-jones-kids.jpg"><img alt="Picture of Barnett and Lonie Jones and children."”
src="images/barnett-loni-jones-kids_small.jpg™ width="200" height="276" /></a></td>

<td><a href="images/barnett-nellie-odell-grace-1997-12-29.jpg"»<img alt="" src="images/barnett-nellie-odell-
grace-1997-12-29 amall.]jpg"™ width="200" height="127" /></a></td>
<td><a href="images/brow-earl-charley-dee.jpg"><img alt="" src="images/brow-earl-charley-dee_small.jpg" widch="200"

height="107" /3</a></td>
Figure 85 - Code for 3 images after optimization

NOTE: The code highlighted below is what will be removed from each image.

<a href="images/barnett-loni-jones-kids.jpg"><img alt="Picture of Barnett and Lonie Jones and children."
src="images/barnett-loni-jones-kids_small.jpg" width="200" height="276" /> <!-- MSComment="autothumbnai
xthumbnail-orig-image="file:///C:/Users/Patricia Geary/Documents/My Web Sites/test-auto-
thumbnail/images/barnett-loni-jones-kids.jpg" --> </a>

Using the auto thumbnail feature is NOT the best way to optimize your images for use on the web.
Instead use your favorite graphics editor. If you don't have one installed on your computer there are
free ones available such as Irfanview and paint.net.

Problems with HTML Strict doctype declaration

NOTE: If you use the HTML Strict doctype shown below, your page will NOT validate with the code used
by the auto thumbnail feature.

<IDOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

Optimizing the code will NOT remove the offending code.

Expression Web 4.0 Tutorials from Install to Publish and More Page 100


http://www.irfanview.com/
http://www.getpaint.net/
http://www.getpaint.net/

XHTML Strict doctype declaration

If you change your doctype declaration to an XHTML Strict doctype, the page will validate and optimizing
the code will remove the thumbnail statement

<IDOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml|1/DTD/xhtml1-
strict.dtd"> <html xmIns="http://www.w3.0rg/1999/xhtml">
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Working with Hyperlinks

Hyperlinks or links are found within nearly all web pages. Links allow your user to click and go to a
different page, a place within a page, an image or another location on the Internet entirely. A hyperlink
can be a word, a group of words, or an image that when clicked on will take you to a new document or a
place within the current document.

Anchor Tags

HTML uses the <a> (anchor) tag to create a link to another document. An anchor can point to another
html page, an image, a text document, or a pdf file among others.

Example of an anchor tag:
<a href="url">Text to be displayed as link</a>

The <a> tag is used to create an anchor to link from, the href attribute is used to address the document
to link to, and the words between the open and close of the anchor tag will be displayed as a hyperlink.

-'”TI'
When you move the cursor over a link in a Web page, the arrow will turn into a little hand. o The
default of the anchor tag is to go to the top of the document it points to.

A URL is an address that specifies a protocol, Web server, and file path. There are two types of URLs:
absolute and relative. An absolute URL contains a full address while a relative URL is missing one or
more parts of the address. However, the web browser obtains the missing information from the page
that contains the URL.

EXAMPLE: Absolute Path Source

<a href="http://www.expression-web-tutorials.com/">Home</a>
EXAMPLE: Relative Path Source

<a href="index.html">Home</a>

Both of the examples used will take you to the Home Page of my site Expression Web Tutorials and

Templates. The browser will simply add the missing parts of the url for the relative link.

NOTE: | tend to use absolute urls for the menus within my site or any reference to the Home Page. For
links to images or other pages within the site, | use relative urls.

Bookmarks or Named Anchors (HTML anchors)

Expression Web 4.0 Tutorials from Install to Publish and More Page 102


http://www.expression-web-tutorials.com/
http://www.expression-web-tutorials.com/

Named anchors are called bookmarks in Expression Web. The name attribute specifies the name of an
anchor and is used to create a bookmark inside an HTML document. If you want the browser to go to a
particular section of a web page, you add a bookmark to that section and then add a hyperlink that uses
the bookmark as its destination. When the site visitor clicks the hyperlink, the browser scrolls to the part
of the page that contains the bookmark. Bookmarks are not displayed in any special way. They are
invisible to the reader.

Example of a named anchor tag:
<a name="anchor">Text to be displayed as link</a>

The name of the anchor can be any text you care to use. However, it should not have spaces in the
name. Use a hyphen or underscore and all lowercase letter. Expression Web uses an underscore as the
default.

Example: <a name="ew-books"></a>Expression Web Books

NOTE: If you highlight the text before you add your bookmark, the Expression Web Books part of the
code above is going to be styled as a hyperlink. To avoid this happening, | place the cursor just before
where | want the named anchor and insert the bookmark.

To link directly to the "ew-books " section of the page on Expression Web Resources, add a # sign and

the name of the anchor to the end of a URL, like this:

<a href="resources.htmlttew-books">Expression Web Books</a>

or like this if you are creating a link to a place in the same document
<a href="#few-books">Expression Web Books</a>

You can also create links to named anchors that might exist on an external website that is not part of
your site.

<a href="http://webaim.org/techniques/alttext/#basics">Alternative Text Basics</a>

Add or Remove a Bookmark in Expression Web
You can add a new bookmark and manage existing bookmarks in the current web page by using the
Bookmark dialog box.

When you bookmark a selection of text, the text displays with a dashed underline in Design view.

<a name="10-bible">10. Family Bible,</a> C. H. Davis, Pasadena, California.

10. Family Bible, C. H. Davis, Pasadena, California.
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<a name="10-bible"></a>10. Family Bible, C. H. Davis, Pasadena, California.

Notice the placement of the closing </a> tag within the code. Choose the method you use depending on
how you want the bookmarked text to display.

When you bookmark an empty location, the bookmark is indicated in Design view by a bookmark icon
when Show and Paragraph Marks are both selected under Formatting Marks on the View menu.

B

Figure 86 - Bookmark formatting mark in Design View

To create a bookmark
Step 1 - Open the web page in either Design view or Code view.

Step 2 - Select the text to which you want to assign a bookmark OR place your cursor in an empty space
next to the text you want to use as a bookmark.

Step 3 - Insert > Bookmark or CTRL + Shift + G.

|Inser‘t Format Tools Table Site DataView

HTML »
ASP.NET Controls > ‘
PHP » ‘
=, Hyperlink.. Ctrl+K
Bookmark... % Ctrl+5hift+G

Figure 87 - Screenshot Insert Bookmark menu item

Step 4 - In the Bookmark dialog box, under Bookmark name, type a name for the bookmark. If you have
selected more than one word, the default for Expression Web is to use the selected text separated with
an underscore.
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Bookmark @ﬂ_hj

Bookmark name:
Design_vievd

Other bookmarks on this page:

Clear

GoTo

OK l ’ Cancel

~

Figure 88 - Bookmark dialog box

To remove a bookmark

Step 1 - Open the web page in either Design view or Code view.

Step 2 - Insert > Bookmark or CTRL + Shift + G

Step 3 - Under Other bookmarks on this page, click the bookmark you want to delete. Click Clear.

Bookmark

i (7] = |

|'\

Bookmark name:
stylesheets

Other bookmarks on this page:

stylesheets
SEO

[y]
In
[s

QK ] [ Cancel

LN

Figure 89 - Clear Bookmark

Tip - You can also remove a bookmark that's selected in your web page by pointing to the tag that
appears in the Quick Tag Selector bar at the top of the web page, and then click the arrow next to the

tag and select Remove Tag.
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<a-
Select Tag
Select Tag Contents
Edit Tag...
Remove Tag
Insert HTML...
Wrap Tag...

Tag Properties...

Figure 90 - Quick Tag Selector drop down menu

HTML Links - the target Attribute

The target attribute specifies where to open the linked document. If you want your hyperlink to open in
a new window the html code would look like this:

<a href=http://www.expression-web-tutorials.com/ target="_blank">Home</a>

Picture hyperlinks

A graphic image can also serve as a hyperlink, linking to another page or a larger image. Hyperlinks on a

picture are not always apparent, however, when your viewer positions the cursor over the hyperlinked
Jhm

image the pointer changes appearance. The pointer will turn into a little hand \J .

e The entire picture can be a hyperlink which allows the site visitor to click any part of the picture
to display its destination. Typically buttons on a page would be this type of hyperlink or a
thumbnail image which opens to a larger image.

e You can also assign one or more hotspots (hyperlinked regions) to a picture which is then called
an image map. Your site visitor can then click a certain area of the image map to display the
corresponding page. For more information on image maps, consult the User Guide under the
Help menu.

To Create or modify a hyperlink

With your web page open, in Design view or Code view, do one of the following:

1. Select the text or image you want to use as the hyperlink. If no text or image is selected, the
destination URL is displayed as the hyperlink text.
2. To modify an existing hyperlink, put your cursor anywhere in the hyperlink.
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=
3. Using either the Common or the Standard toolbar, click Insert Hyperlink icon .

In the Insert Hyperlink or the Edit Hyperlink dialog box, do the following:

-

Edit Hyperlink

I;

Link to: Text to display: |Micr050ﬂ Expression Web 4 Step by Step ScreenTip...

Look in: |ﬁ expression-web-tutorials j & =
e

& _includes/main-menu.html (open) Bookmark...
Current 2 =
% older | © resources.html (open) (=l
- & Untitled_1.html (unsaved) Target Frame...
Place in This d blish
Document o — O_HO_t_p_U IS
VB | graphic-images-pd Parameters...
" U | includes
Create Mew | _wtienf
Document Recent | _wti_pvt
: Files | autumnatpeaks
"] heach -

E-mail

o Address: |http:,",fvw.rw.amazon.cum,fgp,-’pruducUD?BSEBQDE??ie:UTFS&taﬂ Remove Link

oK | Cancel |

- A

Figure 91 - Edit Hyperlink dialog box.

o Text to display — Type or edit the text you want to display as the hyperlink.

e ScreenTip - click ScreenTip. In the Set Hyperlink ScreenTip dialog box, type the text you want to
display, and click OK. The text you typed will display in a floating box when a user's pointer is
over the hyperlink.

NOTE: There is a bug in EW4 that once you click OK, will navigate away from EW. You will need
to return to EW to finish the process.

Set Hyperlink ScreenTip @é]

ScreenTip text:
|Micrnsuft Expression Web 4 Step by Step by Chris Leeds)|

MNote: Custom ScreenTips are supported in Microsoft® Internet

Explorer(® version 4 or later.
OK | Cancel ‘

. ¥,

Figure 92 - Set Hyperlink Screen Tip dialog box

1. Existing File or Web Page allows you to link to a web page or a bookmark on a web page. Select
this option and do one of the following:
0 Inthe Address box, specify the web page or, to locate the page, do one of the following:
=  Browse through the folders and files on your site and select the page/folder you
wish to link to.
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= To browse through the pages and files you've recently visited in Windows
Internet Explorer, either select Browsed Pages or select an item from the
Address drop-down menu.
NOTE: If IE is not your default browser, copy and paste the url you wish to use
in the address box.

= To browse through files you've recently edited in Microsoft Expression Web,
select Recent Files.

= To browse the World Wide Web using Internet Explorer, to the right of the Look
in box, click Browse the Web. In your web browser, browse to the page that you
want to link to, and then press ALT+TAB to switch back to Expression Web. The
location of the page you visited is displayed in the Address box.
NOTE: If IE is not your default browser, copy and paste the url you wish to use
in the address box.

0 Tolink to a bookmark on the page you selected, click Bookmark, and then in the Select
Place in Document dialog box, under Select an existing place in the document, click the
bookmark that you want to use as the destination.

2. Place in This Document allows you to link to a bookmark on the current web page. Select this
option and then, under Select a place in this document, click the bookmark you want to use as
the destination.

NOTE: There is a known bug where if you have Internet Explorer open to a particular website,
the link to that site will be used as your bookmark instead of the link you intended.

3. Create New Document allows you to create a new page at the same time you link to that page.
Select his option, then do the following:

Insert Hyperlink |i|éj
Link to: Text to display: |Ab0ut Our Company ScreenTip...

i6 Name of new document:
Existing File or
Web Page |about-us{

Full path:

; ) file://C:\Users\Patricia\Documents\My Web Change... | Target Frame... |
Place in This Sites\expression-web-tutorials\
Document

]

When to edit:
" Edit the new document |ater

"] (8 Edit the new document now
E-mail
Address

oK | Cancel

Figure 93 - Create New Document and Insert Hyperlink dialog box

0 Inthe Name of new document box, type the name of the file you want to create and
link to. The new document will be created in the folder you are currently in.

0 If you want to create a document in a different location, under Full path, click Change,
browse to the location where you want to create the file, and then click OK. This can be

Expression Web 4.0 Tutorials from Install to Publish and More Page 108



very useful when you are working on menus and need pages that do not yet exist. Just
remember to go back and edit the page.
0 Under When to edit, specify whether you want to edit the file now or later.
4. E-mail Address allows you to link to an E-mail address. Select this option and do the following:

Insert Hyperlink @Iéj
Link to: Text to display: |Pat Geary ScreenTip...

iG E-mail address:
Existing File or
Web Page

|mai\t0:patgeary@comcast.net
Subject:
5 |Quest|on on EW4 Tutorials E-Book

Place in This
Document Recently used e-mail addresses:

~ Parameters...

Create New
Document

2

E-mail -

Address
oK | Cancel

L% 4

Figure 94 - E-mail Address and insert Hyperlink dialog box

0 Inthe E-mail address box, type the e-mail address.
0 Inthe Recently used e-mail addresses box, select an e-mail address.

Optional: If you want to set the subject heading of the e-mail message, in the Subject
box, type the subject. Be aware that some web browsers and e-mail programs may not
use the subject heading that you set.
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5. Target Frame - This option is available only for frames pages and is not available if the
destination of the hyperlink is to an e-mail address. The default target frame is to open the
hyperlink in the same browser window as the current page. Clicking the Target Frame button,
will open a dialog box and allow you to specify the Target Setting as New Window which will
add _blank to the hyperlink code and cause the link to open in a New Window when clicked.

Target Frame ¥ &
| Current frames page Common targets
Page Default {none)
Same Frame I
Whole Page
Parent Frame
(mone)
Target setting
_blank
| Set as page default |
Ok || Cancel |

Figure 95 - Target Frame dialog box

Useful Tips

e Always add a trailing slash to subfolder references. If you link like this:
href="http://www.expression-web-tutorials.com/ew4", you will generate two requests to the
server, the server will first add a slash to the address, and then create a new request like this:
href="http://www.expression-web-tutorials.com/ew4/".

e Named anchors are often used to create "table of contents" at the beginning of a large
document or page. Each chapter within the document is given a named anchor, and links to
each of these anchors are put at the top of the document.

e If a browser does not find the named anchor specified, it goes to the top of the document. No
error occurs.

Additional Resources

e HTML Links by W3schools
e Hyperlinks by Media College

Expression Web 4.0 Tutorials from Install to Publish and More Page 110


http://www.w3schools.com/HTML/html_links.asp
http://www.mediacollege.com/internet/html/hyperlinks.html

Publishing Your Web Site

NOTE: There are some major changes in the User Interface of Expression Web 3.0 and 4.0
New Publishing Features to Expression Web 4.0 include:

e The ability to exclude complete folders from publishing rather than just files.
e The ability to easily Publish Current Page

To mark files or folders that you do not want to publish
Do one of the following:

¢ Inthe Folder List panel, right-click the file or folder that you do not want to publish, and
then click ‘Exclude from Publishing.” If you mark a folder as exclude from publishing, ALL
files within that folder are also marked ‘Exclude from Publishing.’

e In the left-hand pane of Publishing view, right-click the file that you do not want to
publish, and then click ‘Exclude from Publishing’.

Convert to Subsite

o6 Cut

<a Copy

Rename
>< Delete

New >

Publish Selected Files to "Expression Web Tutorials & Templates”
¥ Exclude from Publishing m

Properties...

Figure 96: Exclude from Publishing

= % graphic-images-pd
" 26Foam-m721.jpg
[ tree_branches_and_roots_01.png

[ tree_branches_and_roots_01-sm.png
E= tree15.gif
= treel7.gif
= tree23.gif

% tree-clipart-3.jpg
% tree-clipart-4.jpg
B. tree-images.ixt
B twitter.js

= n ia-buttons

| n images

g M s

Figure 97: Folder/Files Excluded from Publishing
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Publish Current File

There is now an option to ‘Publish Current File.” You must have a page open for this option to be

available. To publish the current file, do one of the following:

e From the ‘Site’ menu, click ‘Publish Current File.’

e From the keyboard Cltrl + Shift +

e From the ‘Standard’ toolbar, clic

Migrate Existing File Def

4 Web 3
Legacy
Proof
4 SiteData
current-dewitt-county
DAR Massanutton Chapter
Default Site
desert-Jequal-columns
expression-web-tutorials
floral-inspiration
freepages
frontpage-to-expression
hoo-ml-originals
HUU
ocean-2-col
webassist-free
Workspaces
Web 4

Publishing Your Website

U

k the ‘Publish Current File’ icon

initions to Expression Web 4

Each time | install a new version of Expression Web, | always
have to re-enter all of the publishing information for each site.
Wouldn't it be nice if | could just copy them for one version to
another? Now you can migrate existing file definitions from
version 3 to version 4. You will need to copy the SiteData
directory (or just certain folders from that directory)

C:\Users\UserName\APPDATA\Microsoft\Expression\Web
3\SiteData

to the equivalent Web 4 location which for me is
%APPDATA%\Microsoft\Expression\Web 4\SiteData

| copied the folder for one of my Expression Web 3 sites that |
had not yet set up in Expression Web 4 and it works perfectly.
Quite a time saver!

Now that you have finished designing your site you will need to publish it for the world to see.
The screenshots for this tutorial were done with a system running Windows Vista Ultimate and
Expression Web 4.0. Yours may look slightly different. Expression Web supports several

different publishing scenarios.

Step 1: Open the website on your computer in Expression Web. Make sure you have saved all
of your pages. You will receive a warning if you have not once you start the publishing process.
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Step 2: If you didn’t set the options for your site while developing your site, check your settings
before attempting to upload/publish. Site > Publishing Settings > Add/Edit .

FREE Setting up Expression Web Ebook by Tina Clarke.

Step 3: Recalculate Hyperlinks: Tools > Recalculate Hyperlinks.

|Too|s Table Site DatalView Pang

Spelling »
Thesaurus... Shift+F7

Set Language...

Accessibility Reports...
Compatibility Reports...
SEO Reports...

CSS Reports...

Customize Toolbars...
Add-in Builder...
Add-Ins...

Recalculate Hyperlinks... D}

Optimize HTML...

Application Options...
Page Editor Options...

Figure 98 - Recalculate Hyperlinks

Step 4: Click Site on the menu, select Publishing

|Site Data View Panels WebAssist Window Help

] New Site... Ctrl+Shift+N
% Open Site... Ctrl+Shift+0
Recent Sites r
Close
Publishing b
Publishing Settings...
Publish Current File to "Expression Web Tutorials & Templates Ctrl+Shift+U
& Publish Changed Files to "Expression Web Tutorials & Templates” Ctrl+Shift«H
(-‘u Publish All Files to "Expression Web Tutorials & Templates” Ctrl+Shift+A
Delete...

Export to Web Package...
Import &

Manage Sites List...
Site Settings...

Figure 99 - Site > Publishing

Step 5: If this is the first time you have published this site, you will receive the message 'Add a
publishing destination.' Click the message and the Connection Settings dialog box will appear.
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There are several things to do on the dialog box that pops up.

1. "Name" - Type the name of the site, i.e., Genealogy Web Creations.

2. "Connection Type" - select FTP, SFTP, FTPS, FrontPage Server Extensions, WebDav, or
File System.

3. "Location" - type the Internet address, including the protocol, of the remote website
that you want to publish folders and files to — for example, ftp://www.your-
domain.com OR http://www.your-domain.com.

4. "Directory" - the folder/directory on the server you are publishing the files to.

NOTE: In the case of 1and1 Linux servers, it would be whichever directory you have
pointed that domain to.

NOTE: In the case of BlueHost, you may enter your domain name or the IP address of
your server. Enter your ftp directory. If this is your main domain (the domain you
opened your account with) enter public_html. If you have pointed your main domain to
a subfolder, enter public_html/name-of-folder. If you are publishing to an addon
domain, you would type public_html/addon-domain-directory.

Make sure you check with your particular host as to the path to publish your files too.
5. "Credentials User name" - your User Name
6. "Credentials Password" - your password

Connection Settings u |j__2@_|

Name: Migrating from FrontPage to Expression Web

Connection Type: FTP

[]

The remaote site server supports File Transfer Protocol (FTF).

Location

Location: ftp:/fwnane. frontpage-to-expression.com EI m

Directory: public_html/frontpage-to-expression

Credentials

User name: patgeary

Password: LTI

Settings

Maximum simultaneous connections: |4 | 2| (1-10)
£2

[/]use Passive FTP

Save I I Cancel

Figure 100 - Connection Settings

Click 'Add.' At this point you are automatically connected to your server.
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If you have already set up your 'Publishing Settings' you will receive the message 'Connect to
current publishing destination.' You can click the message OR you can use the Connect To
button on the Site View tab.

All Files (folder contents)
All Files (folder contents) Genealogy Web Creation H

All Files (flattened list)
Changed Files

Excluded Files

Files in Conflict

Figure 101 - Screenshot Publishing Bar

Step 6: You will see your website (on your computer) in the left window.

Help

Apiily Styles

tpage lo-tpresiien Ppt fwemw Eranipege-to-expresgon.comypublic_Mmi/frontpage-to-expresson
Stats  Modified Author Type Size Name Status Madified Author  Type Size
_includes
Exclu mapas
Exclud, tempiates
# O haccess Unmatched htaccess 388
= hipasewdad Unmatchad Filpassw_. D@
2 2400sham| Conflict Patricia.. shtmi 1378 7 = 0 Conflict shbm 1308
7 = 400shiml Confiict Patricia.. shtm 1696 ¢ B tmi Confiict s 1628
7 % 403shiml Conflict Patricia... shtmi Pl 7 [® s03.5tami Conflict shtm e
7 40dshtmi Conflict . Paticia. shtm 47488 7 (% 40d.shml Conflict st 46598
2 £ 500pmp Confiict Patricia.. 1586 *$ Conflict php 4425
2 E am| Conflict Patricia.. 736 - |7 Conflict st 718
2 % additional-resourceshbmé Confiict Patricia. 582, 7 & acditionad-resources.htmy Confiict hitrni 1567,
7 % confirmation himi Conflict Patricia.. htm 67488 = | # canfirmationhtmi Confiict Ftemi 66328
7 # contactkm| Conflict . Patricia._ 7 (%) contact html Conflict htrnl 56548
O [ discourt-code et Exclud. 7 % eboakhtmi Conflict
Conflict Patricia.. e il Conflict
si0n-web-toolian b Exclud 7 g r-template.imi Conflict
7 * glossarghtmi Conflict Patricia.. 7 E ns-email-form L. Confiict
7 *| hefs-ermor Conflict . Patricia. him 13- email-farm- ph_ Conflict
Sk o g e 2% script-v211phs  Confiict . Pavicia. p 7 % huggins-email-form-scrfgt-v22 1gh. Conflict
7 % huggins-emall-form-seript-v212phes  Conflict Patricia.. 2 %] indexntmi Conflict
7 "2 hupgins-email-form-soipt-v2 2 1php5  Conflict Patricia. 7 Momaincs Conflict
7 & index. bl Conflict . Palricia.. 7 Timain-site.dwt Conflict
O = jan- 2005-clamss-list s Exclud. . Paricia. 7 & students bt Conflict
o Exclud. . Patricia. 7 = testimanial-form.htmi Conflict
Conflict Patricia, 7 (% testimarsalshtmi Conlict
2 main- site,dwt Confict Pafricia.. dwt 2 & thank-youhtm! ConFlict
© & new paypal code tt Exclud.. 2 15 twitter-ewjs Conlict
Q8 ad Exclud_. ) twitter-indes bl Excluded from .
O il paypal-website-code o Exclud.. | twitter-index3.htmi Excluded from
sdentshirmi Confllct Patricia
i Unmat.
Lagt publsh stabes: unknown
Lot publehad

Publishing s Hyperlinie

Figure 102 - Local and Remote Website

Depending on what you are trying to do:

Choose from the View dropdown which files you want to publish. There are three arrows
between the windows. If you want to move just a file or two, you can highlight it, then click the
arrow to copy just that file or files.
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=

Figure 103 — Publishing corresponds with
center bar in previous image

The top arrow 'Publish files to the destination site' is used most often. It publishes your choice
of files from your computer to your server. Keyboard shortcut is Ctrl + Alt + P.

The middle arrow 'Get files from the destination site' is used if you happen to lose your site on
your computer or damage the files, you could use this to download the site or a file from server
to your own computer. Keyboard shortcut is Ctrl + Alt + G.

The bottom double arrows 'Synchronize files,' compares the two sites and moves the data back
and forth until they match. Use this with caution. Keyboard shortcut is Ctrl + Alt + Y.

OR

Step 7: Using the ‘Standard’ toolbar, click the button you wish for the appropriate publishing
operation.

Figure 104: Standard toolbar publishing options

From Left to Right:

e Publish the current File

e Publish all changed files to your site
e Publish all files to your site

o Get all changed files in your site

o Get all files in your site

Once you start the publishing process, you will see your files being transferred. When complete,
you will get a message that your file is finished uploading.
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Last publish status: successful
Last published at: 5/6/2008 9:57:59 PM

Figure 105 - Successful Publish

You can also choose to 'view your publish log files.'

The next time you publish your site; this process will compare the server site with what is on
your computer. If you select ‘Publish all changed file’ only those files that have changed will be
published to the server. No files will be deleted.

If you have problems publishing, check the following:

e Did you type your UserID and password correctly? Remember it’s caSE seNSitiVE, so
must be exactly what you were given by your host.

¢ Did you type the ftp or http address correctly?

¢ If you have a Firewall installed, did you give Expression Web the permissions it needs to
publish?

e Spaces in file names MAY cause problems in uploading files. It is best NOT to use them.
Use a hyphen or underscore to separate the words publishing-website.html or
publishing_website.html NOT publishing website.html.

Once you have finished publishing your site, check online to make sure things are working as
you expect them to.
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How to back up your local website on your
hard drive

This question frequently comes up on various mailing lists. “How can | publish my website on
my hard drive to a backup location on my hard drive?” Unlike Windows Explorer, there is no
Recycle Bin in Expression Web. If you inadvertently delete your website or pages within the
site, you are going to be in a Restore situation.

Back up your website using Expression Web 4.0

Step 1: Open up the site you wish to back up in Expression Web.

Step 2: Recalculate Hyperlinks: Tools > Recalculate Hyperlinks.

GG Table Site  Data View  Pane

Spelling ¥
Thesaurus.., Shift+F7 |

Accessibility Reports...
Compatibility Reports...
C5S Reports...

Recalculate Hyperlinks... [-,:}_'
Optimize HTML...

Application Options...
Page Editor Options...

Figure 106 - Recalculate Hyperlinks

Step 3: Choose Site > Publishing Settings.

il Data View Panels Window  Help

o New Site.., Ctrl+Shift+N
%= Open Site.. Ctrl+Shift+0
Recent Sites ;
Close
Publishing
Publishing Settings... L}

Figure 107 - Site > Publishing Settings Menu
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You can also select 'Publishing' > 'Publishing Settings' (upper right on Site View).

Step 4: In the 'Site Settings' dialog box, click the 'Publishing' tab. The current publishing
destination will show as the default. If you have already published this site to your web hosting
account, click 'Add.’

Site Settings | [ 8|
| General | Preview | Advanced| Publishing |
Publishing Destinations:
Expression Web Tutorials (Default)
l Add... ] [ Edit... l l Delete Set as Default
Options:
[Jinclude subsites
[ optimize HTML during publishing Customize
[/ Log changes during publishing View log file
OK J I Cancel ] Apply

"

Figure 108 - Site Settings > Publishing Tab
Step 5: Choose 'File System' from the 'Connection Type' dropdown menu.
Step 6: In the 'Connection Settings' dialog box, do the following:

1. "Name" - Type the name of the site i.e., EW Tutorials BACKUP.

2. "Location" - Type the folder name where you want the backup published — for
example, C:\Users\Patricia Geary\Documents\My Web Sites\ew-tut-backup OR browse
to the empty web you created beforehand in preparation for backing up.

3. Click 'Add.'
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Connection Settings &I&J

Mame: EW Tutorials BACKUP

Connection Type: |Fjle System El

Use a folder on your computer or on a network as the remote site.

Location

Location: \Documents\My Web Siles\ew—tul—backuﬂEl

Add l ’ Cancel

Figure 109 - Connection Settings

Step 7: Select the newly created backup location from the Connect To dropdown menu

Site View

Folders = WelilyTu Lol E\Y Tutorials BACKUP H

Figure 110 - View Connect To Bar

If the folder does not currently exist, you will be prompted to create it. Click 'Yes' and the
website will be created for you.

Step 8: You will see your website (on your computer) in the left window, and the newly created
backup website (also on your computer) will be on the right hand side. It will be empty if this is
the first time you are backing up your site.
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Figure 111 - Publishing Window

Once connected, click the 'View' dropdown and select one of the following:

e Selecting either of the 'All Files' views will publish all files.
e Selecting the 'Changed Files' view will publish just the changed files.

Depending on what you are trying to do:

Choose from the View dropdown which files you want to publish. There are three arrows
between the windows. If you want to move just a file or two, you can highlight it, then click the
arrow to copy just that file or files.

NOTE: None of the arrows will be available to you until you select a file to publish.

Figure 112 — Publishing

If this is the first time you have backed up your site, do one of the following:

e One the keyboard, use Ctrl + Shift + A
e From the Site menu, select ‘Publish All Files to “Name of Web"’

e From the Standard or Common toolbar, select the icon for ‘Publish all files in your site’

e Hold down the Shift key and highlight the first file/folder on the list, then highlight the last
file/folder on the list. This will highlight all of the files and folders and the top arrow will now be
blue. Select it, and all files will be published to the backup directory
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Once you start the publishing process, you will see your files being transferred. When complete
you will get a message that your file is finished uploading.

Last publish status: successful
Last published at: 7/11/2010 5:58:41 PM

Figure 113 - Successful Publish
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Expression Web 4.0 Add-ins

A new extensibility model will allow you to create add-ins much more easily using html, css, javascript
and a manifest file (xml). Anna Ulrich has an article on how to create add-ins for Expression Web 4 at
Easily create an Add-in for Expression Web 4 with the Add-in Builder.

Jim Cheshire also has a tutorial on Creating an Expression Web Add-in and later this year will be

releasing an EBook

What is an Expression Web Add-in?

An Expression Web Add-in, is an external software package that provides additional or enhanced
functionality within Expression Web 4. One of the first add-ins released is from WebAssist.

How to Install Add-ins?

Step 1: Launch Expression Web 4.0. Go to 'Tools' on the menu and select 'Add-Ins.’

| IS Table Site  Data View  Pang
Spelling L4
Thesaurus... Shift+F7

‘f;' Set Language...

Accessibility Reports...
Compatibility Reports..
SEQ Reports..,

55 Reports...

Add-Ins.. L}

Recalculate Hyperlinks..
Optimize HTML..

Application Options...
Page Editor Options..,

Figure 114 - Tools Add-ins menu
Step 2: In the 'Manage Add-ins' dialog box click the 'Install' button.

NOTE: If this is the first Add-in you have installed, the list will not yet be populated.
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Manage Add-ins

The selected add-ins load when Expression Web starts.

Available add-ins:

Install...

Figure 115: Manage Add-ins dialog

Step 3: Browse to the location on your computer where you downloaded the Add-in. Click 'Open.’
The add-in will end with the file extension .xadd. The add-in will be installed.

Step 4: Once installed, you will be asked if you want to enable the add-in. The screen will give you
all of the information on the particular add-in you are installing. Click 'Yes.'

Add-in Install Complete

A new add-in has been installed. Do you want to enable it?

Name: Payment Buttons for PayPal

Description: Insert Add to Cart. Buy Now, and View Cart buttons to your website to start selling online as soon as

Payment Buttons for PayPal.

Author: WebA
Version: 1.0.0

If you do not know the source of this add-in, or do not want to make it available, dick "No" and then Remove the
add-in using the Manage Add-Ins dialog.

Yes

Figure 116: Enable Add-in

Step 5: If you once again click 'Tools' on the menu bar and select 'Add-ins' you will see the list has
now been populated with your first add-in.
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Manage Add-ins

The selected add-ins load when Expression Web starts.
Available add-ins:

Payment Buttons for PayPal Install..
Description: Insert Add to Cart, Buy Now, and View Cart buttons to your website to start s4
Home Page: http:/fwww.webassist.com
Author: WebAssist
Version: 1.0.0

Remove

Figure 117: Manage Add-ins list

Step 6: To use your Add-in go to 'Panels' and select the Add-in. In this case Payment Buttons for
PayPal.

RENGE Window  Help

Snapshot
IS Folder List Alt+F1

v Tag Properties
v (5SS Properties

Y A A A

v ot sning . s

Payment Buttons for PayPal D}

AutoHide All Panels
Reset Workspace Layout

Figure 118: Add-in menu item
It is as simple as that.

In the coming weeks and months, watch for more and more add-ins to become available. Here are a
few that are currently available.
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Expression Web Free Add-ins

e Expression Web Add-ins by lan Hayes

(o}

Copyright Notice Add-In for Expression Web V4 - This add-in creates a JavaScript
based copyright notice that always updates to the current year and also creates a
static notice, without the year, for the very small percentage of users that don't
have JavaScript enabled.

Sub/Sup Text Add-in for Expression Web 4 - The add-in puts two new buttons on
the "Standard" toolbar for <sub> and <sup> text..

Code Comment Add-In for Expression Web 4 - This add-in adds the comment CSS
functionality and provides three new icons on the "Standard" toolbar

Close All' Add-In for Expression Web V4 allows you to close all open pages in EW
with one click. It puts an icon on both the Standard and Common toolbars
WordPaste Add-In — Allows you to paste clean HTML from Microsoft Word™
documents.

AddFeed Add-In — allows you to easily display a Twitter or RSS feed on your site.
'Attach-JS' Add-In — This add-in adds an item to the 'Insert' menu that allows you
attach a javascript file to your page. It lets you select the file and, if the file is outside
the current web, copies it to the web when you've selected the file.

Code Snippets — a collection of code snippets for Expression Web.

HTMLS5 Placeholder - A simple add-in that adds the HTMLS5 'placeholder.’
WinPop add-in for Expression Web V4 - WinPop creates 'accessible pop-up
windows'. By accessible | mean that they can be read by screen readers and
continue to work if a user has JavaScript turned off.

e |Insert Bing Map Add-in

Expression Web 4.0 Commercial Add-ins

e Advanced CSS Drop Down Menu Expression Web by Ajatix. You can see a sample of this

menu used on my FREE Ocean Template.
e Pure CSS Menu Expression Web by Ajatix

e Lightbox Expression Web by Ajatix - A tutorial on how to add the lightbox to your site and an

example gallery.
e Ajatix Image / Banner Rotator by Ajatix. You can see a sample of the banner/image rotator

used on my FREE Summer Flowers Template.

e Horizontal Menu Advancer by CSSMenuTools
e Accordion Menu Advancer by CSSMenuTools

e LightBox Advancer by CSSMenuTools

e Vertical Menu Advancer by CSSMenuTools
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Learning HTML - HyperText Markup Language

Microsoft Expression Web is a professional Web design tool that is designed to create
standards-based Web sites. The following skills are required in order to use Microsoft
Expression Web successfully:

e XHTML/HTML
e Cascading Style Sheets (CSS) for styling page elements
e  (CSSfor page layout

You can read more about Prerequisites for Using Microsoft Expression Web from Microsoft.

What is HTML?

HTML stands for Hyper Text Markup Language and is a language for describing web pages.
HTML is a markup language rather than a programming language and makes use of HTML tags
to structure the content of your web pages.

Is there a difference between HTML and XHTML? XHTML is more choosy than HTML in that
there are some elements that absolutely must appear in the XHTML markup, but which may be
omitted if you’re using HTML 4 and earlier versions. If you would like more information on
these differences see:

e HTML vs XHTML by W3schools
e HTML Versus XHTML by SitePoint

By default, Expression Web uses XHTML markup!

If you want to successfully work with Expression Web AND be able to troubleshoot your pages,
you will need a good working knowledge of the basic HTML tags you will use to build your web
pages.

HTML Tags

HTML tags are keywords surrounded by angle brackets like <html> and normally come in pairs
<htmlI> </html>. The first tag of the pair is the opening or start tag, the next one the closing or
end tag.

Listed below are ONLY a few of the tags you will need to learn about in order to work on
structuring your web pages.
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<body> tag

The <body> tag defines the document's body and contains all the contents of an HTML
document, such as text, hyperlinks, images, tables, lists, etc. Both an opening and closing tag
are required <body> </body>. Expression Web creates this tag for you when you create a new

page.

<div> tag

The <div> tag defines a division or a section in an HTML document. Both an opening and closing
tag are required <div> </div>. More details on HTML <div> tag

paragraph <p> tag

The <p> tag defines a paragraph. By default, browsers automatically add some space (margin)
before and after each <p> element. You can modify the default styling by changing the margin
style rules using CSS. Both the opening and closing tag are required <p> </p>.

heading <h1> to <h6> tags

The <h1> to <h6> tags are used to define HTML headings. <h1> defines the most important
heading. <h6> defines the least important heading. Both an opening and closing tag are
required <h1> </h1>. Read Heading Tag Structure by James Huggins.

Heading tags are NOT used to style your page but to provide structure to your page.

<ul> tag

The <ul> tag defines an unordered or bulleted list and is used with the <li> tag. Both the
opening and closing tag is required <il> </ul>.

Unordered lists are used to create both vertical and horizontal navigation.

<ol> tag

The <ol> tag defines an ordered list. An ordered list can be numerical or alphabetical. Use the
<li> tag to define list items. Both the opening and closing tag is required <ol> </ol>.

<li> tag

The <li> tag defines a list item and is used in both ordered (<ol>) and unordered (<ul>) lists.
Both the opening and closing tag is required <li> </li>.
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<img> tag

The <img> tag defines an image in an HTML page and has two required attributes: src and alt.
Images are not technically inserted into an HTML page, images are linked to HTML pages. The
<img> tag creates a holding space for the referenced image. The img tag must be properly

closed <img /> The width and height of the image should also be included.

<img alt="Screenshot Include filename." src="images/code-snippet-filename.jpg" width="278"
height="49" />

<a> tag
The <a> tag defines an anchor. An anchor can be used in two ways:

e To create a link to another document, by using the href attribute
e To create a bookmark inside a document, by using the name attribute

The <a> element is usually referred to as a link or a hyperlink. The most important attribute of
the <a> element is the href attribute, which indicates the link’s destination.

<a href="div-containers.html|">HTML div tag</a>

Summary

In summary, the tags listed above are only a few of the ones you will need to structure your
HTML document. You can see a listing of the various tags HTML 4.01 / XHTML 1.0 Reference at
w3schools and Elements by SitePoint

Once you learn the basics of HTML tags, you will find Expression Web much easier to use and it
will go a long way towards helping you troubleshoot problems.

Learning Resources

HTML Coding - Hypertext Markup Language

e W3Schools

e HTML Document Structure

e HTML Tutorial - Table of contents

e A Bare Bones Guide to HTML - The Bare Bones Guide to HTML lists every official HTML tag in
common usage, plus Netscape and Microsoft extensions. Version 4.0 of the Guide is designed to
conform to the HTML 4.0 specification. For official information on the development of HTML,
see the World Wide Web Consortium's HTML activity statement.

e HTML Basic Tutor - This is a website targeting small business owners, beginner web designers
and hobbyist web site owners. The theme of the site is to promote good web design practices
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and coding by implementing the recommendations of the W3C (World Wide Web Consortium)
in a fashion that a person with little or no knowledge of web design can learn from. Each HTML
tutorial is written with the HTML beginner in mind. Currently,

e HTML Code Tutorials - Free Reference Guide for Help with HTML Tags Including Form, Frames,
Tables, and more!

e HTML Dog - Very useful HTML and CSS tutorial place, teaching You everything step by step -
best practices, standards and code with “easy to understand” example.

e Your HTML Source - Teaches you not only how to create your very first homepage, but how to
style it with CSS, add spice with Javascript and create it accessible and SEO friendly.

XHTML - EXtensible HyperText Markup Language

e  XHTML Tutorial - XHTML is a stricter and cleaner version of HTML and is the default used by
Expression Web.

e NYPL Online Style Guide - Created for use by the New York Public Library, it has some excellent
information for your use.

Your next project should be learning the basics of cascading style sheets and how to use them
to style the tags you have just learned to use.
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CSS Basics

Much of the content of this page is based on the User Guide in Expression Web. You can access
the User Guide by selecting Help from the menu, then User Guide.

What is CSS?

CSS stands for Cascading Style Sheets. A style is a set of formatting characteristics that are
defined in a cascading style sheet (CSS) and define how to display HTML elements. You can
apply styles to content in a web page, including text (individual characters or entire
paragraphs), graphics, layers, tables, and even to the body of the entire web page. Styles enable
you to efficiently reuse a set of properties and values without having to set the properties every
time you want to use them.

They also make it much easier to maintain a website. If you decide you want the page
background to be green instead of blue, one change in the style sheet will make the change on
every page the style sheet is attached to.

Cascading Order

What style will be used when there is more than one style specified for an HTML element?

Styles are read in three ways: browser default, style sheets (internal in the <head> or external
via @import or <link>) and inline styles. The default priority is as follows, where number one
has the highest priority:

Inline style (inside an HTML element)

Internal or Embedded style sheet (inside the head tag)
External style sheet

Browser default

PwnNpRE

So, an inline style (inside an HTML element) has the highest priority, which means that it will
override a style declared inside the <head> tag, in an external style sheet, or in a browser (a
default value).

Example of an inline style which tells the browser to render the content of this paragraph as
red:

<p style="color:red">This is a line of content.</p>

Types of Styles
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Selector Declaration Declaration

{font-size: 1em; color: #000000;}

Property Value Property Value

A style rule has two main parts: a selector and one or more declarations. The style can have a
class, element, or ID selector. The above example uses an element for the selector.

A style is defined by its rule set, which consists of a selector, followed by a block of property
declarations that appear between a left curly brace ({) and right curly brace (}).

Each type of style is distinguished from the other style types by its selector;

e aperiod (.) precedes the selector for a class-based style;

e anumber sign (#) precedes the selector for an ID-based style;

¢ and the selector for an element-based style consists only of an HTML element, such as
H1 which is shown in the drawing above.

Element selectors

Use an element selector to define a set of properties that you want every instance of a
particular HTML element to use in a web page. For example, to create a margin of 25 pixels
around all paragraphs (content surrounded by <p> tags) in your web page, you create a style
that uses the p element as its selector and contains declarations for margin properties, as
shown in the following code.

Example of a rule set for an element selector:
p { margin-left: 25px; margin-right: 25px }
Class Selectors

Use a class selector to define a set of properties that you want to use on one or more items in a
web page. If you ever want to modify the style, you can edit the style's rule set and every item
you've applied the style to will automatically reflect the changes.

In the following example, "sidebox" is the style's selector, and "border: #ccccce 2px solid; " is
one property declaration, followed by a second property declaration.

Example of a rule set for a class selector:
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.sidebox { border: 2px solid #CCCCCC; margin: Opx 5px 3px 5px; padding: Opx 3px 15px 3px;
background: #FFFFFF; color: #000000; font-size: 85%; }

Example of a class selector applied to a <div>tag:
<div class="sidebox>
The Testimonials box on the left is the result.

ID selectors

Use an ID selector when you want to define a set of properties for a single item or block of
items that you want to distinguish from all other content in one or more web pages. Use an ID
selector when you want to style a single HTML element in a web page.

Example of a rule set for an ID-based style:

#footer { border-top: 2px solid #564c66; text-align: center; font-size: 80%; padding: 10px Opx;
margin-top: 5px; margin-bottom: 5px; }

Apply this CSS rule to a single HTML element.
<div id="footer">
Inline styles

Use an inline style when you want to define a set of properties for a single item or block of
items in a web page and don't want to reuse that style. Unlike ID, element, and class selectors,
whose properties are defined in either the head section of a web page (internal CSS) or in an
external CSS file, the properties of an inline style (or inline CSS) are defined directly in the HTML
element you want to use the style.

<p style="font-weight: bold; font-style: italic; color: #003A73">
which would render this:

A sentence that looks like this.
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How to Copy and Paste Text so the Code is
Clean

Now that you have learned how to use Expression Web and hopefully have learned the basics of writing
HTML and CSS, you can start adding your content. If you have content from a previous website or from
an MS Word document that you want to copy and paste into your cleanly coded new web site, be
warned that unless done correctly, you will be copying all of the old styles applied to the content you

care copying.

You could copy and paste your content into a plain text editor like Notepad first but you will lose any
hyperlinks that are part of that code. A much quicker (and better) way would be to copy the text from
the Word document or web page by highlighting the text > right click and select Copy.

Next, with your web page open in Expression Web, place your cursor where you want the content to
appear > select Edit > choose Paste Text OR right click and select Paste.

The Paste Text dialog box will appear > select Plain text making sure the Preserve hyperlinks box is
checked. If you have several paragraphs of text select Normal paragraphs without line breaks.

-

Paste Text |ﬁ

As:
Plain text

One <pre> formatted paragraph

Many <pre> formatted paragraphs
Mormal paragraphs with line breaks
Normal paragraphs without line breaks

Result

@ Pastes all of the text and removes any paragraph, row, or other types of
line breaks. If the text to convert contains an empty line or row,
Expression Web encloses the text that follows the empty line or row in a
new tag set.

Preserve hyperlinks

Figure 119 - Paste Text dialog box.

This process will remove any styles attached to the text from the document you copied from. Any style
rules within your style sheet for the <p> tag should automatically be applied to the text you just pasted.

The other selections from the Paste Text dialog are explained below:

‘Select this ” To do this

Remove all formatting, replace line breaks with spaces, and paste the selection as
plain text.

Plain text
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One <pre> formatted Paste the text into a preformatted text tag set (<pre></pre>), which maintains all line
paragraph breaks in the text.

Many <pre> formatted Paste each paragraph of text into a preformatted text tag set (<pre></pre>), which
paragraphs maintains all line breaks in the original text.

Normal paragraphs with Paste the text into a paragraph tag set (<p></p>) and insert a line break tag (<br>)
line breaks wherever a line break occurs in the original text.

Normal paragraphs without

line breaks Paste the text into a paragraph tag set (<p></p>) and remove all line breaks.

There is an even easier way to paste content into your Expression Web page. If you followed the earlier
instructions for Setting Up Expression Web, this option will already have been set. If not, click Tools on

the menu bar > Page Editor Options > General Tab. Make sure under Cut and Paste Options, that Show

Paste Options Button is checked.

Now, when you right click and select Paste, the Paste icon will appear & . When you mouse over the
icon a down arrow will appear. Click the down arrow and you will be presented with these selections:

= -]

(s! Keep Source Formatting
() Bemove Formatting

O Keep HTML Only

(' Keep Text Onby...

Figure 120 - Expanded selections for Paste Icon.

Explanation of what each of the expanded selections do.

‘ Select this H To do this

Preserve the style formatting of the source document, regardless of the styles in the current
Expression Web document. For example, if you copy Heading 2 text from a Microsoft Word

Keep Source
P document and paste it into a page in Expression Web, selecting Keep Source Formatting ensures

F tti
ormatting that the Word Heading 2 style is applied. This is useful if Heading 2 is formatted differently in the
two programs and you want to keep the Word formatting.
Remove . . . . .
. Use this option to remove all formatting, and paste the selection as plain text.
Formatting

Use this option when you want Expression Web to render rather than display HTML tags. For
Keep HTML |lexample, if you copy an example of HTML code from a web browser (such as <i>text</i>) to a page

Only in Expression Web, selecting Keep HTML Only ensures that the example code is rendered as italic
text.
Use this option to remove all formatting, and paste the selection as plain text and set options in the
Keep Text . . . . .
Only Paste Text dialog box to control line breaking and white space. See the next table in the current

topic for more information.
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Create and Style a Data Table

First, make sure that you have set up Expression Web using Tina Clarke's FREE EBook Setting Up
Expression Web 4.0

Create the Table

Step 1: In ‘Design’ view, place the insertion point where you want to insert the table. Do the following:

e On the Menu > Table > Insert Table. NOTE: Do NOT Choose Layout Table.

j Insert Table... [E

Insert »
Delete L4
Select »
Convert 4

able Properties P

Figure 121 - Insert Table Menu

e Onthe ‘Common’ or ‘Standard’ toolbar, click the Insert Table button, then use your pointer to
draw the table; OR Click More Options.
EE = K

.
.
EEEEEN.
.
L]
.

~ More Options h

Figure 122 - Insert Table Button
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e Set the properties that you want.

Insert Table 2] =® ]
Size
Rows: _25 ~ columns: 8 =
Layout
Alignment: Default EI [¥] specify width:
Float: Default (=] 100 )In phels

@I percent

»

Cell padding: |1 [ specify height:

4

Cell spacing: |2

Borders

Size: 1 =
Color: #099999 -
| [¥] collapse table border “
Background -
Color: -

I !Use background picture

Browse... Properties,

Set

|| et as default for new tables

oK l [ Cancel

Figure 123 - Insert Tables Dialog Box

Example Settings in Bold

Size: Set the number of Rows and Columns in your table. Rows: 25: Columns: 8.

Alignment: Set the horizontal alignment of your table. Default.

Float: Set the floating property of your table. Default.

Specify width: Set the width of your table. 100%.

Specify height: Set the height of your table. Do not tick. Leave Blank.

Cell padding: Set the padding between cells. 1.

Cell spacing: Set the spacing within cells. 2.

Borders: Set the size and color of your table borders. 1 #999999 Tick: Collapse table border.
Background: Set the color or background picture you want as your table background.

The following code was added to the head section of my page:

<style type="text/css"> .stylel { width: 100%; border-collapse: collapse; border: 1px solid #999999; }
</style>
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Step 2: On the Manage Styles task panel, > Right Click the just created stylel. > Choose rename class
"stylel."

.stylel i I
Apply Style
Go To Code
Select All 1 Instance(s)

Mew Style...

Mew Style Copy...

Modify Style...

Rename class "stylel”... [:}
Delete

Ve ITH

Attach Style Sheet...
Manage Style Sheet Links...

Figure 124 - Rename class style

In the Rename Class Dialog box, Type "tombstones" or whatever you want to name the class. Make sure
Rename class references in this page is ticked.

Remame Class ¥ Hﬂj

Defined in:  table-example.himl
Current name:  stylel

Hew nama: [tormbstanes

¥ | Rename dass references in this page.

[ | ow _i.Cunwl.

Figure 125 - Rename Class Dialog Box
You will see that the class has been renamed "tombstones," and the code for your table changed to:

<table class="tombstones">

Step 3: From the ‘Manage’ or ‘Apply Styles’ task panel, > Click New Style.
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In the New Style dialog box, type or select the following:

New Style | 7]
Eekeaoc Ry fombstones i |Z| || Apply new style to document selection
Define in: | Current page lz‘ URL: F—
Category:
Font o =
line-height: El = [ox
Background vertical-align: top El: %
Sorder text-align: E|
Box -
Position text-indent: E| = o
Layout white-space: El
List —
word-spacing: em
Table pacid El £
letter-spacing: E|: am
Praview:
AaBbYyGgLlJj
Brenplion: vertical-align: top; border: 1px solid #999999; padding: Spx
l 0K ] l Cancel l I Apply

Figure 126 - Create New Style Dialog Box

Selector: Type .tombstone td

Define in: Current page

Block: vertical-align: top

Border: sold 1px #999999

Box: padding: 5px (untick: Same for all if you do NOT want the same amount of padding in the cells.

You will see the style being created in the display area.
Click OK, and the styles will be applied to the table cells.

Step 4: If you want the top row to be a header row, > select the first row of data cells. > Right click > Cell
Properties > Tick: header cell. > Click OK.

You can create a new style for the header row by using the same method as described above, OR copy
and paste the style you created for:

.tombstones td { vertical-align: top; border: 1px solid #999999; padding: 5px; }
changing the td to th. The default style will be centered and bold
.tombstones th { vertical-align: top; border: 1px solid #999999; padding: 5px; }

Example: Blank Styled Table
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Style an Already Created Data Table

If you have a data table already created, you can easily add styling to it.
Step 1: Open the page with the table you wish to style in Expression Web.
From the Quick Tag Selector, > Click <table>.

From the Manage or Apply Styles task panel, > Click New Style.

In the New Style dialog box, type or select the following:

Selector: Type .prisoners

Define in: Current page

Border: solid 1px #999999

Box: Uncheck: Margins: Same for all Top: 10px Bottom: 10 px (this will add some spacing between the
top and bottom of your table from other text.

Position: width: 100%

Make sure you have ticked Apply Style to document selection.
The following code will be added to the head section of your page

<style type="text/css"> .prisoners { border: 1px solid #999999; width: 100%; border-collapse: collapse;
margin-top: 10px; margin-bottom: 10px; } </style>

Step 3: From the ‘Manage’ or ‘Apply Styles’ task panel, > Click New Style.
In the New Style dialog box, type or select the following:

Selector: Type .prisoners td

Define in: Current page

Block: vertical-align: top

Border: sold 1px #999999

Box: padding: 5px (untick: Same for all if you do NOT want the same amount of padding in the cells.

You will see the style being created in the display area.
Click OK, and the styles will be applied to the table cells.

Step 4: If you want the top row to be a header row > select the first row of data cells, > right click > Cell
Properties > Tick: header cell > Click OK.
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You can create a new style for the header row by using the same method as described above OR copy

and paste the style you created for:

.prisoners td { vertical-align: top; border: 1px solid #999999; padding: 5px; }

changing the td to th. The default style will be centered and bold.

.prisoners th { vertical-align: top; border: 1px solid #999999; padding: 5px; }

Example: Fully Styled Data Table

Points to Remember in Working with Tables

Consider the size of your table. Remember, not everyone has a high speed Internet connection.
If you have a very large table, consider breaking it into smaller tables.

If you want the table centered on the page, add auto for the left and right margins.

If you will be using the same styling on more than one table, move the table styles to an
external style sheet where you can use them over and over again.

Using this method, your table code remains clean and your styles can be modified much more
easily.

You can add other style rules to the classes like font-size:small.

Make your tables accessible

Sample Styled Accessible Table Using External Style Sheet
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